summaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-04-20 06:26:09 +0000
committerSteven Barth <cyrus@openwrt.org>2015-04-20 06:26:09 +0000
commit38519cad0ba2b557b9aefb9717ba91840c706760 (patch)
treeea847bb00638f927eed93362ba530e8ebf27bce8 /package/network/utils/iproute2
parent610ce30c3a4a0e9d833a1b4d2bb46aa62a6731b3 (diff)
downloadmaster-31e0f0ae-38519cad0ba2b557b9aefb9717ba91840c706760.tar.gz
master-31e0f0ae-38519cad0ba2b557b9aefb9717ba91840c706760.tar.bz2
master-31e0f0ae-38519cad0ba2b557b9aefb9717ba91840c706760.zip
iproute2: update to v4.0.0
The most significant change from the previous version is the trimming of the 300-ip_tiny.patch to lib/utils.c where a section previously patched had vanished. That section of the patch was removed. Built and lightly tested on ar71xx against uClibc and musl. Signed-off-by: Russell Senior <russell@personaltelco.net> SVN-Revision: 45512
Diffstat (limited to 'package/network/utils/iproute2')
-rw-r--r--package/network/utils/iproute2/Makefile4
-rw-r--r--package/network/utils/iproute2/patches/006-no_sctp.patch2
-rw-r--r--package/network/utils/iproute2/patches/120-libnetlink-pic.patch4
-rw-r--r--package/network/utils/iproute2/patches/300-ip_tiny.patch22
-rw-r--r--package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch2
5 files changed, 9 insertions, 25 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index a2dae6d61b..308ec578e1 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
-PKG_VERSION:=3.19.0
+PKG_VERSION:=4.0.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
-PKG_MD5SUM:=237083a1e3c388cde7a115a5724dc72a
+PKG_MD5SUM:=3adc263ade4ee76c35032e8f50b54108
PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/iproute2/patches/006-no_sctp.patch b/package/network/utils/iproute2/patches/006-no_sctp.patch
index a3b2880d5a..4aa988415e 100644
--- a/package/network/utils/iproute2/patches/006-no_sctp.patch
+++ b/package/network/utils/iproute2/patches/006-no_sctp.patch
@@ -8,7 +8,7 @@
case IPPROTO_DCCP:
default: /* XXX */
if (sel->sport_mask)
-@@ -1336,7 +1335,6 @@ static int xfrm_selector_upspec_parse(st
+@@ -1337,7 +1336,6 @@ static int xfrm_selector_upspec_parse(st
switch (sel->proto) {
case IPPROTO_TCP:
case IPPROTO_UDP:
diff --git a/package/network/utils/iproute2/patches/120-libnetlink-pic.patch b/package/network/utils/iproute2/patches/120-libnetlink-pic.patch
index 26cc569dbf..19ccd1a936 100644
--- a/package/network/utils/iproute2/patches/120-libnetlink-pic.patch
+++ b/package/network/utils/iproute2/patches/120-libnetlink-pic.patch
@@ -7,5 +7,5 @@
-CFLAGS += -fPIC
+CFLAGS += $(FPIC)
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o
-
+ UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o \
+ names.o
diff --git a/package/network/utils/iproute2/patches/300-ip_tiny.patch b/package/network/utils/iproute2/patches/300-ip_tiny.patch
index 4295d0aae9..14518dce1c 100644
--- a/package/network/utils/iproute2/patches/300-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/300-ip_tiny.patch
@@ -70,7 +70,7 @@
};
--- a/lib/utils.c
+++ b/lib/utils.c
-@@ -630,6 +630,7 @@ const char *rt_addr_n2a(int af, const vo
+@@ -642,6 +642,7 @@ const char *rt_addr_n2a(int af, const vo
case AF_INET:
case AF_INET6:
return inet_ntop(af, addr, buf, buflen);
@@ -78,7 +78,7 @@
case AF_IPX:
return ipx_ntop(af, addr, buf, buflen);
case AF_DECnet:
-@@ -638,6 +639,7 @@ const char *rt_addr_n2a(int af, const vo
+@@ -650,6 +651,7 @@ const char *rt_addr_n2a(int af, const vo
memcpy(dna.a_addr, addr, 2);
return dnet_ntop(af, &dna, buf, buflen);
}
@@ -86,22 +86,6 @@
default:
return "???";
}
-@@ -713,6 +715,7 @@ const char *format_host(int af, int len,
- case AF_INET6:
- len = 16;
- break;
-+#ifndef IPROUTE2_TINY
- case AF_IPX:
- len = 10;
- break;
-@@ -723,6 +726,7 @@ const char *format_host(int af, int len,
- len = 2;
- break;
- #endif
-+#endif
- default: ;
- }
- }
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -4,6 +4,10 @@ ifeq ($(IP_CONFIG_SETNS),y)
@@ -114,4 +98,4 @@
+
CFLAGS += $(FPIC)
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o
+ UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o \
diff --git a/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch b/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
index 7b82933181..f5d2dfe9b9 100644
--- a/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
+++ b/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
@@ -24,7 +24,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
--- a/include/linux/rtnetlink.h
+++ b/include/linux/rtnetlink.h
-@@ -203,6 +203,7 @@ enum {
+@@ -208,6 +208,7 @@ enum {
RTN_THROW, /* Not in this table */
RTN_NAT, /* Translate this address */
RTN_XRESOLVE, /* Use external resolver */