summaryrefslogtreecommitdiffstats
path: root/package/network/utils/iftop/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-10-10 13:21:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-10-10 13:21:30 +0000
commitc748c36d2c5d2c1741f7e1e4c7e37304f62b38b9 (patch)
tree0fca528c03b177dbd77c0565653aa27e29c3c0b6 /package/network/utils/iftop/Makefile
parent711fdc3b099689a42bdb80b321ab9223f325adce (diff)
downloadmaster-31e0f0ae-c748c36d2c5d2c1741f7e1e4c7e37304f62b38b9.tar.gz
master-31e0f0ae-c748c36d2c5d2c1741f7e1e4c7e37304f62b38b9.tar.bz2
master-31e0f0ae-c748c36d2c5d2c1741f7e1e4c7e37304f62b38b9.zip
iftop: move to trunk and add myself as maintainer
SVN-Revision: 33702
Diffstat (limited to 'package/network/utils/iftop/Makefile')
-rw-r--r--package/network/utils/iftop/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/package/network/utils/iftop/Makefile b/package/network/utils/iftop/Makefile
new file mode 100644
index 0000000000..9feb059148
--- /dev/null
+++ b/package/network/utils/iftop/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iftop
+PKG_VERSION:=0.17
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.ex-parrot.com/~pdw/iftop/download
+PKG_MD5SUM:=062bc8fb3856580319857326e0b8752d
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/iftop
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libpcap +libncurses +libpthread
+ TITLE:=display bandwith usage on an interface
+ URL:=http://www.ex-parrot.com/~pdw/iftop/
+endef
+
+define Package/iftop/description
+ iftop does for network usage what top(1) does for CPU usage. It
+ listens to network traffic on a named interface and displays a
+ table of current bandwidth usage by pairs of hosts. Handy for
+ answering the question 'why is our ADSL link so slow?'.
+endef
+
+define Package/iftop/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/iftop $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,iftop))