summaryrefslogtreecommitdiffstats
path: root/package/network/utils/ebtables/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-10 11:36:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-10 11:36:49 +0000
commit1c8148a8588f116d81881159e2222dc49e89314a (patch)
tree3c8eb924e6dab294b3fbbb7f1e97a5d6c1b96204 /package/network/utils/ebtables/Makefile
parentaee7bf2fca458ea88e4a2e61e4099957116cdbba (diff)
downloadmaster-31e0f0ae-1c8148a8588f116d81881159e2222dc49e89314a.tar.gz
master-31e0f0ae-1c8148a8588f116d81881159e2222dc49e89314a.tar.bz2
master-31e0f0ae-1c8148a8588f116d81881159e2222dc49e89314a.zip
ebtables: fix miscompilation on 64bit targets
The musl build "fix" introduced in r45108 removed all netinet/ether.h includes, which made the prototypes of ether_aton and ether_ntoa unavailable. As a result, the compiler assumed they return int instead of a pointer. This currupted the pointer on 64bit targets, causing ebtables to segfault in commands containing MAC addresses. Since r46161 made it possible to include both the kernel and the libc if_ether.h as long as the libc version is included first, this patch changes the fix to remove the linux/if_ether.h from the ebtables source (so the fixed version from the kernel is used) and ensures netinet/ether.h is included early. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 46292
Diffstat (limited to 'package/network/utils/ebtables/Makefile')
-rw-r--r--package/network/utils/ebtables/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/ebtables/Makefile b/package/network/utils/ebtables/Makefile
index 4f6d7f5323..30bf426d77 100644
--- a/package/network/utils/ebtables/Makefile
+++ b/package/network/utils/ebtables/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
PKG_VERSION:=2.0.10-4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/ebtables