summaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-17 13:57:56 +0000
committerJohn Crispin <john@openwrt.org>2015-01-17 13:57:56 +0000
commitff3448adaa7ec9be964f20f1f5095b8082aa1b19 (patch)
tree4cee8c43a47e45e5a3065ee3f863098169e6b44e /package/network/utils/curl/Makefile
parent6774c43dde78ba04ebf6f53842504c48f85de39c (diff)
downloadmaster-31e0f0ae-ff3448adaa7ec9be964f20f1f5095b8082aa1b19.tar.gz
master-31e0f0ae-ff3448adaa7ec9be964f20f1f5095b8082aa1b19.tar.bz2
master-31e0f0ae-ff3448adaa7ec9be964f20f1f5095b8082aa1b19.zip
curl: allow enabling https protocol
Provide optional --enable-https flag for curl. Signed-off-by: Lars Kruse <devel@sumpfralle.de> SVN-Revision: 43997
Diffstat (limited to 'package/network/utils/curl/Makefile')
-rw-r--r--package/network/utils/curl/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index f78fa9e9a2..1a374951c1 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -37,6 +37,7 @@ PKG_CONFIG_DEPENDS := \
LIBCURL_GNUTLS \
LIBCURL_GOPHER \
LIBCURL_HTTP \
+ LIBCURL_HTTPS \
LIBCURL_IMAP \
LIBCURL_LDAP \
LIBCURL_LDAPS \
@@ -113,6 +114,7 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_LIBCURL_GOPHER),--enable,--disable)-gopher \
$(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr",--without-gnutls) \
$(if $(CONFIG_LIBCURL_HTTP),--enable,--disable)-http \
+ $(if $(CONFIG_LIBCURL_HTTPS),--enable,--disable)-https \
$(if $(CONFIG_LIBCURL_IMAP),--enable,--disable)-imap \
$(if $(CONFIG_LIBCURL_LDAP),--enable,--disable)-ldap \
$(if $(CONFIG_LIBCURL_LDAPS),--enable,--disable)-ldaps \