summaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-04-17 12:51:41 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2016-04-17 12:51:41 +0000
commita4d646cf155f187892b6461d364546957dafd59d (patch)
tree971c72c7ec0844a45657ca6b01ad0e94d3f14e86 /package/network/utils/curl/Makefile
parenta2b15e6c1d84bda852ad4309b1ce3d5939898e00 (diff)
downloadmaster-31e0f0ae-a4d646cf155f187892b6461d364546957dafd59d.tar.gz
master-31e0f0ae-a4d646cf155f187892b6461d364546957dafd59d.tar.bz2
master-31e0f0ae-a4d646cf155f187892b6461d364546957dafd59d.zip
curl: add config option for NTLM support
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 49183
Diffstat (limited to 'package/network/utils/curl/Makefile')
-rw-r--r--package/network/utils/curl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index eada1aa596..319c0b710d 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -65,7 +65,8 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_LIBCURL_THREADED_RESOLVER \
CONFIG_LIBCURL_TLS_SRP \
CONFIG_LIBCURL_UNIX_SOCKETS \
- CONFIG_LIBCURL_VERBOSE
+ CONFIG_LIBCURL_VERBOSE \
+ CONFIG_LIBCURL_NTLM
include $(INCLUDE_DIR)/package.mk
@@ -99,6 +100,7 @@ define Package/libcurl/config
endef
TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
CONFIGURE_ARGS += \
--disable-debug \