summaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl/Makefile
diff options
context:
space:
mode:
authorDirk Neukirchen <dirkneukirchen@web.de>2016-05-19 13:27:41 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-19 16:56:34 +0200
commit6aebc6b16b3e2e7058b8b5ab1ffa7f65920541ff (patch)
tree62bc4cfbb2ff827b145b856189aba40ff81e28f5 /package/network/utils/curl/Makefile
parent9d37095fd055a2c11b4d62978fe22b2e6f8e2c32 (diff)
downloadmaster-31e0f0ae-6aebc6b16b3e2e7058b8b5ab1ffa7f65920541ff.tar.gz
master-31e0f0ae-6aebc6b16b3e2e7058b8b5ab1ffa7f65920541ff.tar.bz2
master-31e0f0ae-6aebc6b16b3e2e7058b8b5ab1ffa7f65920541ff.zip
curl: update to 7.49
fixes: CVE-2016-3739: TLS certificate check bypass with mbedTLS/PolarSSL - remove crypto auth compile fix curl changelog of 7.46 states its fixed - fix mbedtls and cyassl usability #19621 : add path to certificate file (from Mozilla via curl) and provide this in a new package tested on ar71xx w. curl/mbedtls/wolfssl Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Diffstat (limited to 'package/network/utils/curl/Makefile')
-rw-r--r--package/network/utils/curl/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index af38ed4aed..4b41ac33e9 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=curl
-PKG_VERSION:=7.48.0
+PKG_VERSION:=7.49.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
ftp://ftp.planetmirror.com/pub/curl/ \
http://www.mirrormonster.com/curl/download/ \
http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=d42e0fc34a5cace5739631cc040974fe
+PKG_MD5SUM:=7416aaff4a9210b43edda7615ffa4169
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
@@ -109,7 +109,6 @@ CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--disable-manual \
- --without-ca-bundle \
--without-nss \
--without-libmetalink \
--without-librtmp \
@@ -117,11 +116,11 @@ CONFIGURE_ARGS += \
$(call autoconf_bool,CONFIG_IPV6,ipv6) \
\
$(if $(CONFIG_LIBCURL_AXTLS),--with-axtls="$(STAGING_DIR)/usr" --without-ca-path,--without-axtls) \
- $(if $(CONFIG_LIBCURL_CYASSL),--with-cyassl="$(STAGING_DIR)/usr" --without-ca-path,--without-cyassl) \
- $(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr" --with-ca-path=/etc/ssl/certs,--without-gnutls) \
- $(if $(CONFIG_LIBCURL_OPENSSL),--with-ssl="$(STAGING_DIR)/usr" --with-ca-path=/etc/ssl/certs,--without-ssl) \
- $(if $(CONFIG_LIBCURL_POLARSSL),--with-polarssl="$(STAGING_DIR)/usr" --with-ca-path=/etc/ssl/certs,--without-polarssl) \
- $(if $(CONFIG_LIBCURL_MBEDTLS),--with-mbedtls="$(STAGING_DIR)/usr" --without-ca-path,--without-mbedtls) \
+ $(if $(CONFIG_LIBCURL_CYASSL),--with-cyassl="$(STAGING_DIR)/usr" --without-ca-path --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt,--without-cyassl) \
+ $(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr" --without-ca-bundle --with-ca-path=/etc/ssl/certs,--without-gnutls) \
+ $(if $(CONFIG_LIBCURL_OPENSSL),--with-ssl="$(STAGING_DIR)/usr" --without-ca-bundle --with-ca-path=/etc/ssl/certs,--without-ssl) \
+ $(if $(CONFIG_LIBCURL_POLARSSL),--with-polarssl="$(STAGING_DIR)/usr" --without-ca-bundle --with-ca-path=/etc/ssl/certs,--without-polarssl) \
+ $(if $(CONFIG_LIBCURL_MBEDTLS),--with-mbedtls="$(STAGING_DIR)/usr" --without-ca-path --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt,--without-mbedtls) \
\
$(if $(CONFIG_LIBCURL_LIBIDN),--with-libidn="$(STAGING_DIR)/usr",--without-libidn) \
$(if $(CONFIG_LIBCURL_SSH2),--with-libssh2="$(STAGING_DIR)/usr",--without-libssh2) \