summaryrefslogtreecommitdiffstats
path: root/package/network/services
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-25 17:59:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-25 17:59:08 +0000
commit634c8c215cd5416f2776b02e488bf2c3d0edd59c (patch)
tree09924653013fe1649300d3e24237406dc8d163e3 /package/network/services
parentee3eade28597b7fe4157c55b816af69a94ca4d0a (diff)
downloadmaster-31e0f0ae-634c8c215cd5416f2776b02e488bf2c3d0edd59c.tar.gz
master-31e0f0ae-634c8c215cd5416f2776b02e488bf2c3d0edd59c.tar.bz2
master-31e0f0ae-634c8c215cd5416f2776b02e488bf2c3d0edd59c.zip
uhttpd: fix time_t type mismatch on 32bit systems
The previous update introducing LFS support unconditionally changed the sprintf() pattern used to print the file modification time to use PRIx64. Explicitely convert the st_mtime member of the stat struct to uint64_t in order to avoid type mismatch errors when building for non-64bit targets. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44138
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/uhttpd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 9cd28e25d0..1bb0084392 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2015-01-25
+PKG_VERSION:=2015-01-25.1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=7352ec423fb99a7970b0765287503abee05a56cd
+PKG_SOURCE_VERSION:=d404cd06b657cdcd97555362abec7966e339fd6d
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=ISC