summaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-09-29 11:26:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-09-29 11:26:09 +0000
commitf8ee248701820fd4118197e45fe2c6a58225e1c2 (patch)
treee8d7e223b172ed76411499265b0ceeee99733836 /package/network/services/uhttpd
parent2beabf6c1158e8c74acdb076829bcce210352839 (diff)
downloadmaster-31e0f0ae-f8ee248701820fd4118197e45fe2c6a58225e1c2.tar.gz
master-31e0f0ae-f8ee248701820fd4118197e45fe2c6a58225e1c2.tar.bz2
master-31e0f0ae-f8ee248701820fd4118197e45fe2c6a58225e1c2.zip
uhttpd: add a config option for using ustream-polarssl, and use it by default
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 38250
Diffstat (limited to 'package/network/services/uhttpd')
-rw-r--r--package/network/services/uhttpd/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 7c3ea5b055..2ff2ff798c 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -51,7 +51,10 @@ endef
define Package/uhttpd-mod-tls
$(Package/uhttpd/default)
TITLE+= (TLS plugin)
- DEPENDS:=uhttpd +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
+ DEPENDS:=uhttpd \
+ +PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
+ +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
+ +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
endef
define Package/uhttpd-mod-tls/description
@@ -62,7 +65,10 @@ define Package/uhttpd-mod-tls/config
choice
depends on PACKAGE_uhttpd-mod-tls
prompt "TLS Provider"
- default PACKAGE_uhttpd-mod-tls_cyassl
+ default PACKAGE_uhttpd-mod-tls_polarssl
+
+ config PACKAGE_uhttpd-mod-tls_polarssl
+ bool "PolarSSL"
config PACKAGE_uhttpd-mod-tls_cyassl
bool "CyaSSL"