summaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-10-07 22:14:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-10-07 22:14:48 +0000
commitb3454610702d452f790aa40e7a40b536a73ee8ab (patch)
treed2a778a83dcd3fad6e5363538d50295cb255a7b8 /package/network/services/uhttpd
parent468c1fb3206461109c3d52022bfd6c48d043bacb (diff)
downloadmaster-31e0f0ae-b3454610702d452f790aa40e7a40b536a73ee8ab.tar.gz
master-31e0f0ae-b3454610702d452f790aa40e7a40b536a73ee8ab.tar.bz2
master-31e0f0ae-b3454610702d452f790aa40e7a40b536a73ee8ab.zip
uhttpd: fix keep-alive bug (#20607, #20661)
The two commits 5162e3b0ee7bd1d0fd6e75e1ca7993a1834b5291 "allow request handlers to disable chunked reponses" and 618493e378e2239f0d30902e47adfa134e649fdc "file: disable chunked encoding for file responses" broke the chunked transfer encoding handling for proc responses in keep-alive connections that followed a file response with http status 204 or 304. The effect of this bug is that cgi responses following a 204 or 304 one where sent neither in chunked encoding nor with a content-length header, causing browsers to stall until the keep alive timeout was reached. Fix the logic flaw by inverting the chunk prevention flag in the client state and by testing the chunked encoding preconditions every time instead of once upon client (re-)initialization. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 47161
Diffstat (limited to 'package/network/services/uhttpd')
-rw-r--r--package/network/services/uhttpd/Makefile4
-rwxr-xr-xpackage/network/services/uhttpd/files/uhttpd.init5
2 files changed, 2 insertions, 7 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 51f2bdc1ce..a9a535aee8 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2015-09-07
+PKG_VERSION:=2015-10-08
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=993cace15114a0f06f720f34a4748ab54b695f0d
+PKG_SOURCE_VERSION:=7ed2edc40dd6d0171266f3bfbc96466e1d25e3cd
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=ISC
diff --git a/package/network/services/uhttpd/files/uhttpd.init b/package/network/services/uhttpd/files/uhttpd.init
index 1ebe38e8d3..a3e09c44e7 100755
--- a/package/network/services/uhttpd/files/uhttpd.init
+++ b/package/network/services/uhttpd/files/uhttpd.init
@@ -131,11 +131,6 @@ start_instance()
}
procd_close_instance
-
- # Check if daemon is running, if not then
- # re-execute in foreground to display error.
-# sleep 1 && service_check $UHTTPD_BIN || \
-# $UHTTPD_BIN -f $UHTTPD_ARGS
}
service_triggers()