summaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-11-11 19:14:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-11-11 19:14:01 +0000
commit8a1d77efed4e915a52e31f6f73a42bd6353353d3 (patch)
treea3f2d6826d53e1486bea5889bab2a07dbc15f3ab /package/network/services/uhttpd
parentc902a76f4dabbe49904e8a2ebe210e729b91283a (diff)
downloadmaster-31e0f0ae-8a1d77efed4e915a52e31f6f73a42bd6353353d3.tar.gz
master-31e0f0ae-8a1d77efed4e915a52e31f6f73a42bd6353353d3.tar.bz2
master-31e0f0ae-8a1d77efed4e915a52e31f6f73a42bd6353353d3.zip
uhttpd: return after processing -d switch, only set ubus prefix if not already defined
SVN-Revision: 38743
Diffstat (limited to 'package/network/services/uhttpd')
-rw-r--r--package/network/services/uhttpd/Makefile4
-rw-r--r--package/network/services/uhttpd/files/ubus.default8
2 files changed, 8 insertions, 4 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index be1a1e27f1..46a39a1718 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2013-09-13
+PKG_VERSION:=2013-11-11
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=8eb20e0aad7412468975b2c9ce7e374ea3084e42
+PKG_SOURCE_VERSION:=881d6102cf1f7bc6b54ab395c5e4addbfe1ed34c
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
diff --git a/package/network/services/uhttpd/files/ubus.default b/package/network/services/uhttpd/files/ubus.default
index ba6c289f84..397456db6a 100644
--- a/package/network/services/uhttpd/files/ubus.default
+++ b/package/network/services/uhttpd/files/ubus.default
@@ -1,2 +1,6 @@
-uci set uhttpd.main.ubus_prefix=/ubus
-uci commit uhttpd
+#!/bin/sh
+
+if [ -z "$(uci -q get uhttpd.main.ubus_prefix)" ]; then
+ uci set uhttpd.main.ubus_prefix=/ubus
+ uci commit uhttpd
+fi