summaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-08-25 12:39:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-08-25 12:39:34 +0000
commit730589281ee8940016bacf856d566e7ceab719af (patch)
tree2ccff2053c741b628b368365c7d2dbe3fe17dfe0 /package/network/services/uhttpd
parent7a1f4c50fa052bc40116f9e243ab15f0fba1ebf2 (diff)
downloadmaster-31e0f0ae-730589281ee8940016bacf856d566e7ceab719af.tar.gz
master-31e0f0ae-730589281ee8940016bacf856d566e7ceab719af.tar.bz2
master-31e0f0ae-730589281ee8940016bacf856d566e7ceab719af.zip
uhttpd: do not configure TLS parameters if libustream-ssl is not present
A quite frequent problem after sysupgrading from an older, SSL enabled build is that ustream-ssl is not installed so uhttpd fails to come up again due to https listening directives in the preserved configuration. Skip key/cert and ssl listen options when libustream-ssl.so is not present. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 42284
Diffstat (limited to 'package/network/services/uhttpd')
-rw-r--r--package/network/services/uhttpd/Makefile4
-rwxr-xr-xpackage/network/services/uhttpd/files/uhttpd.init2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index ba2ca55b04..a93b40a085 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010-2013 Jo-Philipp Wich <jow@openwrt.org>
+# Copyright (C) 2010-2014 Jo-Philipp Wich <jow@openwrt.org>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2014-06-11
+PKG_VERSION:=2014-08-25
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/uhttpd/files/uhttpd.init b/package/network/services/uhttpd/files/uhttpd.init
index 608aa9d36b..2e94609606 100755
--- a/package/network/services/uhttpd/files/uhttpd.init
+++ b/package/network/services/uhttpd/files/uhttpd.init
@@ -109,7 +109,7 @@ start_instance()
config_get UHTTPD_KEY "$cfg" key /etc/uhttpd.key
config_get UHTTPD_CERT "$cfg" cert /etc/uhttpd.crt
- [ -n "$https" ] && {
+ [ -f /lib/libustream-ssl.so ] && [ -n "$https" ] && {
[ -f "$UHTTPD_CERT" -a -f "$UHTTPD_KEY" ] || {
config_foreach generate_keys cert
}