summaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-22 15:05:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-22 15:05:04 +0000
commita4c7a953e5fb58a075c7cdedf8b2f8c86a771f22 (patch)
tree22143c36e42f9cc96123f9bfc933b68a7c2ddad1 /package/network/services/uhttpd/Makefile
parent7b845ca9c7c34e464446e5ad66ca4344773652af (diff)
downloadmaster-31e0f0ae-a4c7a953e5fb58a075c7cdedf8b2f8c86a771f22.tar.gz
master-31e0f0ae-a4c7a953e5fb58a075c7cdedf8b2f8c86a771f22.tar.bz2
master-31e0f0ae-a4c7a953e5fb58a075c7cdedf8b2f8c86a771f22.zip
uhttpd: always turn on TLS support, include ustream-ssl as a build dependency
SVN-Revision: 35295
Diffstat (limited to 'package/network/services/uhttpd/Makefile')
-rw-r--r--package/network/services/uhttpd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 6f3d1507ae..f03ecc4398 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -18,11 +18,11 @@ PKG_SOURCE_VERSION:=14e3971c37e6feb0ec5eda0988e07d8a786ba9f9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
-PKG_CONFIG_DEPENDS = CONFIG_PACKAGE_uhttpd-mod-tls
+PKG_BUILD_DEPENDS = ustream-ssl
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-
define Package/uhttpd/default
SECTION:=net
CATEGORY:=Network
@@ -102,7 +102,7 @@ endef
TARGET_LDFLAGS += -lcrypt
-CMAKE_OPTIONS = -DTLS_SUPPORT=$(if $(CONFIG_PACKAGE_uhttpd-mod-tls),on,off)
+CMAKE_OPTIONS = -DTLS_SUPPORT=on
define Package/uhttpd/install
$(INSTALL_DIR) $(1)/etc/init.d