summaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-26 23:34:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-26 23:34:01 +0000
commiteedf17dc9e9f89dc5d2f23cf858b2787275b6c67 (patch)
tree6e0e74ae2cf73f7988f6612d8110f4d97d47a861 /package/network/services/hostapd/Makefile
parentcec80c72678c970c459d26239a7be89d5b225f0e (diff)
downloadmaster-31e0f0ae-eedf17dc9e9f89dc5d2f23cf858b2787275b6c67.tar.gz
master-31e0f0ae-eedf17dc9e9f89dc5d2f23cf858b2787275b6c67.tar.bz2
master-31e0f0ae-eedf17dc9e9f89dc5d2f23cf858b2787275b6c67.zip
hostapd: add dependency to hostapd-common
'hostapd-common' is needed by all of the variants for wifi to function correctly (a number of the target profiles simply select 'wpad-mini'). Signed-off-by: Nathan Hintz <nlhintz@hotmail.com> SVN-Revision: 45048
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index b9a705143f..7cbbe8d5d5 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -103,7 +103,7 @@ define Package/hostapd/Default
CATEGORY:=Network
TITLE:=IEEE 802.1x Authenticator
URL:=http://hostap.epitest.fi/
- DEPENDS:=$(DRV_DEPENDS) +libubus
+ DEPENDS:=$(DRV_DEPENDS) +hostapd-common +libubus
endef
define Package/hostapd
@@ -144,13 +144,14 @@ define Package/wpad/Default
SECTION:=net
CATEGORY:=Network
TITLE:=IEEE 802.1x Authenticator/Supplicant
+ DEPENDS:=$(DRV_DEPENDS) +hostapd-common +libubus
URL:=http://hostap.epitest.fi/
endef
define Package/wpad
$(call Package/wpad/Default)
TITLE+= (full)
- DEPENDS:=$(DRV_DEPENDS) +WPA_SUPPLICANT_OPENSSL:libopenssl +libubus
+ DEPENDS+=+WPA_SUPPLICANT_OPENSSL:libopenssl
VARIANT:=wpad-full
endef
@@ -162,7 +163,6 @@ endef
define Package/wpad-mini
$(call Package/wpad/Default)
TITLE+= (WPA-PSK only)
- DEPENDS:=$(DRV_DEPENDS) +libubus
VARIANT:=wpad-mini
endef