summaryrefslogtreecommitdiffstats
path: root/package/network/services/dropbear/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-29 16:59:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-29 16:59:26 +0000
commitad52658be722f2024dd645a1a7228209e8bf7c23 (patch)
tree3781e39aa0e8d75676750651bfd96bbb1af89d13 /package/network/services/dropbear/Makefile
parentf5fce5e0da49d27caec70d64695b4a2d9bab8d44 (diff)
downloadmaster-31e0f0ae-ad52658be722f2024dd645a1a7228209e8bf7c23.tar.gz
master-31e0f0ae-ad52658be722f2024dd645a1a7228209e8bf7c23.tar.bz2
master-31e0f0ae-ad52658be722f2024dd645a1a7228209e8bf7c23.zip
dropbear: update to 2014.63
Upstream changelog: https://matt.ucc.asn.au/dropbear/CHANGES This adds elliptic curve cryptography (ECC) support as an option, disabled by default. dropbear mips 34kc uClibc binary size: before: 161,672 bytes after, without ECC (default): 164,968 after, with ECC: 198,008 Signed-off-by: Catalin Patulea <cat@vv.carleton.ca> SVN-Revision: 40297
Diffstat (limited to 'package/network/services/dropbear/Makefile')
-rw-r--r--package/network/services/dropbear/Makefile24
1 files changed, 22 insertions, 2 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 02be76110f..692199e8aa 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -8,26 +8,32 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
-PKG_VERSION:=2013.59
+PKG_VERSION:=2014.63
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
http://matt.ucc.asn.au/dropbear/releases/ \
https://dropbear.nl/mirror/releases/
-PKG_MD5SUM:=6c1e6c2c297f4034488ffc95e8b7e6e9
+PKG_MD5SUM:=7066bb9a2da708f3ed06314fdc9c47fd
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
PKG_BUILD_PARALLEL:=1
+PKG_CONFIG_DEPENDS:=CONFIG_DROPBEAR_ECC
+
include $(INCLUDE_DIR)/package.mk
define Package/dropbear/Default
URL:=http://matt.ucc.asn.au/dropbear/
endef
+define Package/dropbear/config
+ source "$(SOURCE)/Config.in"
+endef
+
define Package/dropbear
$(call Package/dropbear/Default)
SECTION:=net
@@ -72,6 +78,20 @@ CONFIGURE_ARGS += \
TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ # Enforce that all replacements are made, otherwise options.h has changed
+ # format and this logic is broken.
+ for OPTION in DROPBEAR_ECDSA DROPBEAR_ECDH DROPBEAR_CURVE25519; do \
+ awk 'BEGIN { rc = 1 } \
+ /'$$$$OPTION'/ { $$$$0 = "$(if $(CONFIG_DROPBEAR_ECC),,// )#define '$$$$OPTION'"; rc = 0 } \
+ { print } \
+ END { exit(rc) }' $(PKG_BUILD_DIR)/options.h \
+ >$(PKG_BUILD_DIR)/options.h.new && \
+ mv $(PKG_BUILD_DIR)/options.h.new $(PKG_BUILD_DIR)/options.h || exit 1; \
+ done
+endef
+
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \