summaryrefslogtreecommitdiffstats
path: root/package/network/services/dropbear/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-29 17:10:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-29 17:10:52 +0000
commit3ecffab05061b49c74768fe6c1d695ea84fcf863 (patch)
treec815ced0b56214df454624465f3f5bffc0d34b60 /package/network/services/dropbear/Makefile
parentf2fdd8ebdb1617218201d16eeb54a5a905768764 (diff)
downloadmaster-31e0f0ae-3ecffab05061b49c74768fe6c1d695ea84fcf863.tar.gz
master-31e0f0ae-3ecffab05061b49c74768fe6c1d695ea84fcf863.tar.bz2
master-31e0f0ae-3ecffab05061b49c74768fe6c1d695ea84fcf863.zip
dropbear: move options.h editing to Build/Configure
fixes incremental build with change to CONFIG_DROPBEAR_ECC drop --with-shared which is unknown to configure Patch by Catalin Patulea <cat@vv.carleton.ca> SVN-Revision: 40300
Diffstat (limited to 'package/network/services/dropbear/Makefile')
-rw-r--r--package/network/services/dropbear/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 692199e8aa..b2bd8cc605 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -59,7 +59,6 @@ define Package/dropbearconvert
endef
CONFIGURE_ARGS += \
- --with-shared \
--disable-pam \
--enable-openpty \
--enable-syslog \
@@ -78,8 +77,9 @@ CONFIGURE_ARGS += \
TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
-define Build/Prepare
- $(call Build/Prepare/Default)
+define Build/Configure
+ $(Build/Configure/Default)
+
# Enforce that all replacements are made, otherwise options.h has changed
# format and this logic is broken.
for OPTION in DROPBEAR_ECDSA DROPBEAR_ECDH DROPBEAR_CURVE25519; do \