summaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-12-27 20:42:26 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-12-27 20:42:26 +0000
commitf80cee1ce5785e6e5b2131bf7af2a10175ff57ca (patch)
tree71df4da4d766527c38377a8d597001a7b088355d /package/network/ipv6
parent5359183b7e5260ba6f3d983d6f3103e54afd62b4 (diff)
downloadmaster-31e0f0ae-f80cee1ce5785e6e5b2131bf7af2a10175ff57ca.tar.gz
master-31e0f0ae-f80cee1ce5785e6e5b2131bf7af2a10175ff57ca.tar.bz2
master-31e0f0ae-f80cee1ce5785e6e5b2131bf7af2a10175ff57ca.zip
6in4: Corrected tunnelbroker tunnel update URL
Changed the tunnel update URL into format tunnelbrokers example has, that made it work again. Current method gives "Username/Password Authentication Failed." when I tried the wget line manually and logread eventually says also "6in4: update failed". With corrected URL it works fine: "good 111.222.333.444" or "nochg 111.222.333.444" and logread concurs with success, and tunnel actually updates. Tested-by: Vaasa Hacklab <info@vaasa.hacklab.fi> Signed-off-by: Sami Olmari <sami@olmari.fi> SVN-Revision: 48006
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index 9eca57af63..b51b12d482 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=22
+PKG_VERSION:=23
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index 59747a3783..05471db14b 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -108,7 +108,7 @@ proto_6in4_setup() {
fi
}
- local url="$http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
+ local url="$http://$username:$password@ipv4.tunnelbroker.net/nic/update?hostname=$tunnelid"
local try=0
local max=3