summaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-06-09 21:18:55 +0000
committerSteven Barth <cyrus@openwrt.org>2015-06-09 21:18:55 +0000
commite23052ab749ae9e9aa272caee7c065f7a98c82c1 (patch)
treee537091c90e0310d57b9145bc41fee6a9cff86bf /package/network/ipv6
parent2fed0fffe1559f42c197750308ce03eff58b51af (diff)
downloadmaster-31e0f0ae-e23052ab749ae9e9aa272caee7c065f7a98c82c1.tar.gz
master-31e0f0ae-e23052ab749ae9e9aa272caee7c065f7a98c82c1.tar.bz2
master-31e0f0ae-e23052ab749ae9e9aa272caee7c065f7a98c82c1.zip
map: add sleep work-around for lw4o6 race-condition
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 45936
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/map/Makefile2
-rwxr-xr-xpackage/network/ipv6/map/files/map.sh3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
index 89d34de1b4..3757ed6088 100644
--- a/package/network/ipv6/map/Makefile
+++ b/package/network/ipv6/map/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=map
PKG_VERSION:=4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/map/files/map.sh b/package/network/ipv6/map/files/map.sh
index 5e37aa25b3..98a493dd57 100755
--- a/package/network/ipv6/map/files/map.sh
+++ b/package/network/ipv6/map/files/map.sh
@@ -39,6 +39,9 @@ proto_map_setup() {
( proto_add_host_dependency "$cfg" "::" "$tunlink" )
+ # fixme: handle RA/DHCPv6 address race for LW
+ [ "$type" = lw4o6 ] && sleep 5
+
if [ -z "$rule" ]; then
rule="type=$type,ipv6prefix=$ip6prefix,prefix6len=$ip6prefixlen,ipv4prefix=$ipaddr,prefix4len=$ip4prefixlen"
[ -n "$psid" ] && rule="$rule,psid=$psid"