summaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-01-13 17:25:43 +0000
committerSteven Barth <cyrus@openwrt.org>2013-01-13 17:25:43 +0000
commitb58a13cb2c65b202c0ffe84fa6c02376cb994b7d (patch)
tree6d7314e6125ad2b356a167ac4d8937c4f6adfbeb /package/network/ipv6
parentfde5b934fd2cdbaa179329030b8a16c34b11ffea (diff)
downloadmaster-31e0f0ae-b58a13cb2c65b202c0ffe84fa6c02376cb994b7d.tar.gz
master-31e0f0ae-b58a13cb2c65b202c0ffe84fa6c02376cb994b7d.tar.bz2
master-31e0f0ae-b58a13cb2c65b202c0ffe84fa6c02376cb994b7d.zip
ipv6-support: don't use disable_ipv6
SVN-Revision: 35134
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/ipv6-support/Makefile2
-rwxr-xr-xpackage/network/ipv6/ipv6-support/files/dhcpv6.sh5
2 files changed, 3 insertions, 4 deletions
diff --git a/package/network/ipv6/ipv6-support/Makefile b/package/network/ipv6/ipv6-support/Makefile
index 0d596d4d3b..74286e79b8 100644
--- a/package/network/ipv6/ipv6-support/Makefile
+++ b/package/network/ipv6/ipv6-support/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ipv6-support
-PKG_VERSION:=2013-01-02
+PKG_VERSION:=2013-01-13
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/ipv6-support/files/dhcpv6.sh b/package/network/ipv6/ipv6-support/files/dhcpv6.sh
index 9609f04d5c..5a668cd9b1 100755
--- a/package/network/ipv6/ipv6-support/files/dhcpv6.sh
+++ b/package/network/ipv6/ipv6-support/files/dhcpv6.sh
@@ -20,9 +20,8 @@ if [ "$state" == "started" ]; then
conf_set "$device" accept_ra 2
conf_set "$device" forwarding 2
- # Trigger RS
- conf_set "$device" disable_ipv6 1
- conf_set "$device" disable_ipv6 0
+ # Send RS on interface
+ [ -x /usr/sbin/6relayd ] && /usr/sbin/6relayd -s "$device"
exit 0
elif [ "$state" == "stopped" ]; then