summaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 10:15:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 10:15:29 +0000
commit99856ebf5cbdd520cf58cef9cf2323a4a6168ebc (patch)
treebe4e6b3ad5d4a3998bdfbdaa4e2c481c00115726 /package/network/ipv6
parent8353ed85f2c13feb1b010f556e3d27c7133e489a (diff)
downloadmaster-31e0f0ae-99856ebf5cbdd520cf58cef9cf2323a4a6168ebc.tar.gz
master-31e0f0ae-99856ebf5cbdd520cf58cef9cf2323a4a6168ebc.tar.bz2
master-31e0f0ae-99856ebf5cbdd520cf58cef9cf2323a4a6168ebc.zip
6in4: use uclient-fetch instead of wget/curl
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48391
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/6in4/Makefile4
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh27
2 files changed, 7 insertions, 24 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index 9eca57af63..5d9355fa54 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=22
+PKG_VERSION:=23
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/6in4
SECTION:=net
CATEGORY:=Network
- DEPENDS:=@IPV6 +kmod-sit
+ DEPENDS:=@IPV6 +kmod-sit +uclient-fetch
TITLE:=IPv6-in-IPv4 configuration support
MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
PKGARCH:=all
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index 59747a3783..c358a222fa 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -82,40 +82,23 @@ proto_6in4_setup() {
[ -n "$updatekey" ] && password="$updatekey"
local http="http"
- local urlget="wget"
+ local urlget="uclient-fetch"
local urlget_opts="-qO-"
local ca_path="${SSL_CERT_DIR-/etc/ssl/certs}"
- if [ -n "$(which curl)" ]; then
- urlget="curl"
- urlget_opts="-s -S"
- if curl -V | grep "Protocols:" | grep -qF "https"; then
- http="https"
- urlget_opts="$urlget_opts --capath $ca_path"
- fi
- fi
- if [ "$http" = "http" ] &&
- wget --version 2>&1 | grep -qF "+https"; then
- urlget="wget"
- urlget_opts="-qO- --ca-directory=$ca_path"
- http="https"
- fi
+ [ -f /lib/libustream-ssl.so ] && http=https
[ "$http" = "https" -a -z "$(find $ca_path -name "*.0" 2>/dev/null)" ] && {
- if [ "$urlget" = "curl" ]; then
- urlget_opts="$urlget_opts -k"
- else
- urlget_opts="$urlget_opts --no-check-certificate"
- fi
+ urlget_opts="$urlget_opts --no-check-certificate"
}
- local url="$http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
+ local url="$http://ipv4.tunnelbroker.net/nic/update?hostname=$tunnelid"
local try=0
local max=3
(
set -o pipefail
while [ $((++try)) -le $max ]; do
- if proto_6in4_update $urlget $urlget_opts "$url" 2>&1 | \
+ if proto_6in4_update $urlget $urlget_opts --user="$username" --password="$password" "$url" 2>&1 | \
sed -e 's,^Killed$,timeout,' -e "s,^,update $try/$max: ," | \
logger -t "$link";
then