summaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-02-26 07:42:12 +0000
committerSteven Barth <cyrus@openwrt.org>2015-02-26 07:42:12 +0000
commit547ac608130a1a300123f8a5cd54aad8c4a37ac4 (patch)
tree6f989d92fbd87b50a742136b98d10106765a23ed /package/network/ipv6
parent0f365e4cb9f357ffa9a77454eb5f93d844fe9cbf (diff)
downloadmaster-31e0f0ae-547ac608130a1a300123f8a5cd54aad8c4a37ac4.tar.gz
master-31e0f0ae-547ac608130a1a300123f8a5cd54aad8c4a37ac4.tar.bz2
master-31e0f0ae-547ac608130a1a300123f8a5cd54aad8c4a37ac4.zip
6rd: honor tunlink in host dependency
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 44541
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/6rd/Makefile4
-rw-r--r--package/network/ipv6/6rd/files/6rd.sh2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/ipv6/6rd/Makefile b/package/network/ipv6/6rd/Makefile
index 82195c8c3b..d3e4bf6974 100644
--- a/package/network/ipv6/6rd/Makefile
+++ b/package/network/ipv6/6rd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6rd
-PKG_VERSION:=7
+PKG_VERSION:=8
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
@@ -19,7 +19,7 @@ define Package/6rd
CATEGORY:=Network
DEPENDS:=+kmod-ipv6 +kmod-sit
TITLE:=6rd configuration support
- MAINTAINER:=Stéphan Kochen <stephan@kochen.nl>
+ MAINTAINER:=Steven Barth <cyrus@openwrt.org>
PKGARCH:=all
endef
diff --git a/package/network/ipv6/6rd/files/6rd.sh b/package/network/ipv6/6rd/files/6rd.sh
index 042d98559f..287f569885 100644
--- a/package/network/ipv6/6rd/files/6rd.sh
+++ b/package/network/ipv6/6rd/files/6rd.sh
@@ -23,7 +23,7 @@ proto_6rd_setup() {
return
}
- ( proto_add_host_dependency "$cfg" 0.0.0.0 )
+ ( proto_add_host_dependency "$cfg" 0.0.0.0 "$tunlink" )
[ -z "$ipaddr" ] && {
local wanif="$tunlink"