summaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-06-10 15:54:24 +0000
committerSteven Barth <cyrus@openwrt.org>2015-06-10 15:54:24 +0000
commit4734c4459b2423c07b2752498e9ac2397ae7bfe1 (patch)
treed34c0d3b0ea3eb26c6841c41df0326a9ca2ce44d /package/network/ipv6
parent908b9065bb891a0e1286744272abab7662e2882d (diff)
downloadmaster-31e0f0ae-4734c4459b2423c07b2752498e9ac2397ae7bfe1.tar.gz
master-31e0f0ae-4734c4459b2423c07b2752498e9ac2397ae7bfe1.tar.bz2
master-31e0f0ae-4734c4459b2423c07b2752498e9ac2397ae7bfe1.zip
odhcp6c: work around RIOs matching PIOs as sent by some apple routers
Thanks to Mikael Abrahamsson for reporting. Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 45941
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile2
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.script4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index a90f5ce162..d0935eb8b6 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2015-06-09
+PKG_VERSION:=2015-06-10
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.script b/package/network/ipv6/odhcp6c/files/dhcpv6.script
index 650c9b2e8f..84eb706ebc 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.script
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.script
@@ -88,6 +88,10 @@ setup_interface () {
if [ -z "$gw" ]; then
proto_add_ipv6_route "$addr" "$mask" "$gw" "$metric" "$valid"
+
+ # work around if there is a PIO matching a RIO
+ # Linux seems to prefer source-dest over dest-only even if metric is higher
+ proto_add_ipv6_route "$addr" "$mask" "$gw" "$metric" "$valid" "$addr/$mask"
else
for prefix in $PREFIXES $ADDRESSES; do
local paddr="${prefix%%,*}"