summaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-03 08:01:08 +0000
committerJohn Crispin <john@openwrt.org>2014-11-03 08:01:08 +0000
commitc10d97484a43375a0446dafc8cb4072e26502f37 (patch)
tree9a871898dd0dbf9e198388067465019e8577ccaf /package/network/config
parente2d82442b7261014bf352a57ee76bee2df0d14de (diff)
downloadmaster-31e0f0ae-c10d97484a43375a0446dafc8cb4072e26502f37.tar.gz
master-31e0f0ae-c10d97484a43375a0446dafc8cb4072e26502f37.tar.bz2
master-31e0f0ae-c10d97484a43375a0446dafc8cb4072e26502f37.zip
Add more license tags with SPDX identifiers
Note, that licensing stuff is a nightmare: many packages does not clearly state their licenses, and often multiple source files are simply copied together - each with different licensing information in the file headers. I tried hard to ensure, that the license information extracted into the OpenWRT's makefiles fit the "spirit" of the packages, e.g. such small packages which come without a dedicated source archive "inherites" the OpenWRT's own license in my opinion. However, I can not garantee that I always picked the correct information and/or did not miss license information. Signed-off-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 43155
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/firewall/Makefile2
-rw-r--r--package/network/config/qos-scripts/Makefile3
-rw-r--r--package/network/config/soloscli/Makefile3
-rw-r--r--package/network/config/swconfig/Makefile3
4 files changed, 11 insertions, 0 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index b1d50a19f1..e224c92803 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -19,6 +19,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=ISC
+PKG_LICENSE:=ISC
+PKG_LICENSE_FILES:=
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
diff --git a/package/network/config/qos-scripts/Makefile b/package/network/config/qos-scripts/Makefile
index a6690a161a..257b2f7572 100644
--- a/package/network/config/qos-scripts/Makefile
+++ b/package/network/config/qos-scripts/Makefile
@@ -13,6 +13,9 @@ PKG_RELEASE:=6
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=
+
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/soloscli/Makefile b/package/network/config/soloscli/Makefile
index 12bc15eaca..ba55a1e4a7 100644
--- a/package/network/config/soloscli/Makefile
+++ b/package/network/config/soloscli/Makefile
@@ -16,6 +16,9 @@ PKG_SOURCE_URL:=@SF/openadsl
PKG_MD5SUM:=c398866de3c059b14eb953c89d698124
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=soloscli/COPYING.GPL
+
PKG_BUILD_DIR:=$(BUILD_DIR)/solos-pci-$(PKG_VERSION)
PKG_BUILD_PARALLEL:=1
diff --git a/package/network/config/swconfig/Makefile b/package/network/config/swconfig/Makefile
index 7d0f30e7bb..fb951da3ac 100644
--- a/package/network/config/swconfig/Makefile
+++ b/package/network/config/swconfig/Makefile
@@ -13,6 +13,9 @@ PKG_RELEASE:=10
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0 LGPL-2.1
+PKG_LICENSE_FILES:=
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/kernel.mk