summaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2014-11-08 12:24:49 +0000
committerSteven Barth <cyrus@openwrt.org>2014-11-08 12:24:49 +0000
commit990b501ec4128aa1bc94922adf6b4592570bcc6f (patch)
treef70b33095d4169a4837b1e4f77116dc37f7ff29b /package/network/config
parent07754ac29777a0a81d2ed74a7fb79a223760693e (diff)
downloadmaster-31e0f0ae-990b501ec4128aa1bc94922adf6b4592570bcc6f.tar.gz
master-31e0f0ae-990b501ec4128aa1bc94922adf6b4592570bcc6f.tar.bz2
master-31e0f0ae-990b501ec4128aa1bc94922adf6b4592570bcc6f.zip
netifd: fix default ORO-setting for 6rd
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 43214
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/netifd/Makefile2
-rwxr-xr-xpackage/network/config/netifd/files/lib/netifd/proto/dhcp.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 008af6183d..ea8980f4bb 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_VERSION:=2014-10-24
+PKG_VERSION:=2014-10-24.1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
index 6668b49c21..d4c483d690 100755
--- a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
+++ b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
@@ -40,7 +40,7 @@ proto_dhcp_setup() {
[ "$broadcast" = 1 ] && broadcast="-B" || broadcast=
[ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"
[ -n "$iface6rd" ] && proto_export "IFACE6RD=$iface6rd"
- [ -n "$iface6rd" ] && append dhcpopts "-O 212"
+ [ "$iface6rd" != 0 -a -f /lib/netifd/proto/6rd.sh ] && append dhcpopts "-O 212"
[ -n "$zone6rd" ] && proto_export "ZONE6RD=$zone6rd"
[ -n "$zone" ] && proto_export "ZONE=$zone"
[ -n "$mtu6rd" ] && proto_export "MTU6RD=$mtu6rd"