summaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2012-12-03 12:46:57 +0000
committerMirko Vogt <mirko@openwrt.org>2012-12-03 12:46:57 +0000
commit4c30952394850cf5f2b5d22a2bc50c2151b009f5 (patch)
tree107f2a3d1612dee87d83f4ae62ba1f9e326a6755 /package/network/config
parenta7220cd9f870af7165ff3531ce2756f1f1b0f72e (diff)
downloadmaster-31e0f0ae-4c30952394850cf5f2b5d22a2bc50c2151b009f5.tar.gz
master-31e0f0ae-4c30952394850cf5f2b5d22a2bc50c2151b009f5.tar.bz2
master-31e0f0ae-4c30952394850cf5f2b5d22a2bc50c2151b009f5.zip
Make ltq-dsl-app compile with an eglibc-based toolchain
Signed-Off-By: Frank Meerkötter <frank@meerkoetter.org> SVN-Revision: 34468
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/ltq-dsl-app/Makefile2
-rw-r--r--package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch23
2 files changed, 25 insertions, 0 deletions
diff --git a/package/network/config/ltq-dsl-app/Makefile b/package/network/config/ltq-dsl-app/Makefile
index 664bc5d8e1..37a72ee336 100644
--- a/package/network/config/ltq-dsl-app/Makefile
+++ b/package/network/config/ltq-dsl-app/Makefile
@@ -17,6 +17,8 @@ PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
PKG_MD5SUM:=ee315306626b68794d3d3636dabfe161
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+PKG_FIXUP:=autoreconf
+
PKG_CONFIG_DEPENDS:=\
CONFIG_LTQ_DSL_ENABLE_SOAP \
CONFIG_LTQ_DSL_ENABLE_DSL_EVENT_POLLING
diff --git a/package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch b/package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch
new file mode 100644
index 0000000000..268f868e07
--- /dev/null
+++ b/package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch
@@ -0,0 +1,23 @@
+--- a/configure.in
++++ b/configure.in
+@@ -29,6 +29,8 @@ AC_C_VOLATILE
+ #AC_FUNC_STRTOD
+ #AC_CHECK_FUNCS([ftime gethostbyname gettimeofday localtime_r memset select socket strchr strerror strstr strtoull])
+
++AC_SEARCH_LIBS([clock_gettime],[rt])
++
+ #
+ # save the configure arguments
+ #
+--- a/src/dsl_cpe_linux.h
++++ b/src/dsl_cpe_linux.h
+@@ -45,7 +45,8 @@
+ #include <arpa/inet.h>
+ #include <sys/socket.h> /* socket */
+ #include <sys/sem.h> /* semget */
+-#include <semaphore.h> /* sem_t */
++#include <semaphore.h> /* sem_t */
++#include <limits.h>
+
+ #ifdef DSL_DEBUG_TOOL_INTERFACE
+ #include <sys/socket.h>