summaryrefslogtreecommitdiffstats
path: root/package/network/config/swconfig
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-17 12:51:24 +0000
committerJohn Crispin <john@openwrt.org>2015-07-17 12:51:24 +0000
commitd42b6c1afb7320860fa406f12b165fa4295464c7 (patch)
tree43ddab03add1b0cedba107f5775bd819f1727d8f /package/network/config/swconfig
parenteff79253f2fd3b4e7f1000b09e1fedf8f52d7af4 (diff)
downloadmaster-31e0f0ae-d42b6c1afb7320860fa406f12b165fa4295464c7.tar.gz
master-31e0f0ae-d42b6c1afb7320860fa406f12b165fa4295464c7.tar.bz2
master-31e0f0ae-d42b6c1afb7320860fa406f12b165fa4295464c7.zip
swconfig: libsw.so should be installed into /usr/lib/
otherwise it's not picked up by toolchain: staging_dir/toolchain-mipsel_24kec+dsp_gcc-4.8-linaro_musl-1.1.10/lib/gcc/mipsel-openwrt-linux-musl/4.8.3/../../../../mipsel-openwrt-linux-musl/bin/ld: cannot find -lsw Signed-off-by: Roman Yeryomin <roman@advem.lv> SVN-Revision: 46406
Diffstat (limited to 'package/network/config/swconfig')
-rw-r--r--package/network/config/swconfig/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/config/swconfig/Makefile b/package/network/config/swconfig/Makefile
index 3c2ec3e387..b62b059873 100644
--- a/package/network/config/swconfig/Makefile
+++ b/package/network/config/swconfig/Makefile
@@ -46,8 +46,8 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_BUILD_DIR)/swlib.h $(1)/usr/include/
- $(INSTALL_DIR) $(1)/lib
- $(CP) $(PKG_BUILD_DIR)/libsw.so $(1)/lib/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libsw.so $(1)/usr/lib/
endef
define Package/swconfig/install