summaryrefslogtreecommitdiffstats
path: root/package/network/config/soloscli
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 12:45:01 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 12:45:01 +0000
commit35d3c91c863b4a66acd07daf740fbbaf702d4b19 (patch)
tree5e3f09ab02d1884ced69a13c2fc9688f53a01a69 /package/network/config/soloscli
parent3306a4f9abb667e470633c18fc5c2cfe33dd34a0 (diff)
downloadmaster-31e0f0ae-35d3c91c863b4a66acd07daf740fbbaf702d4b19.tar.gz
master-31e0f0ae-35d3c91c863b4a66acd07daf740fbbaf702d4b19.tar.bz2
master-31e0f0ae-35d3c91c863b4a66acd07daf740fbbaf702d4b19.zip
soloscli: upgrade to 1.04
- The package does not compile at the moment. Since there is a new upstream version avaiable, use this new source instead. - Upstream has already included our both patches. - This is only compile tested, since I do not own any test hardware. Signed-off-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 40940
Diffstat (limited to 'package/network/config/soloscli')
-rw-r--r--package/network/config/soloscli/Makefile11
-rw-r--r--package/network/config/soloscli/patches/000-Makefile.patch21
-rw-r--r--package/network/config/soloscli/patches/001-newline.patch15
-rw-r--r--package/network/config/soloscli/patches/001-no-driver.patch11
-rw-r--r--package/network/config/soloscli/patches/002-cflags.patch12
5 files changed, 28 insertions, 42 deletions
diff --git a/package/network/config/soloscli/Makefile b/package/network/config/soloscli/Makefile
index 9a7cd894f9..f0533c9ac4 100644
--- a/package/network/config/soloscli/Makefile
+++ b/package/network/config/soloscli/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,16 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=soloscli
-PKG_VERSION:=0.11
-PKG_RELEASE:=3
+PKG_VERSION:=1.04
+PKG_RELEASE:=1
PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/openadsl
-PKG_MD5SUM:=ab3f3fa654ef7c3a402980eca094e690
-
-PKG_INSTALL:=1
+PKG_MD5SUM:=c398866de3c059b14eb953c89d698124
PKG_BUILD_DIR:=$(BUILD_DIR)/solos-pci-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/soloscli/patches/000-Makefile.patch b/package/network/config/soloscli/patches/000-Makefile.patch
deleted file mode 100644
index 914d6d886b..0000000000
--- a/package/network/config/soloscli/patches/000-Makefile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/Makefile 2010-06-14 14:17:11.000000000 +1000
-+++ b/Makefile 2010-06-14 14:17:54.000000000 +1000
-@@ -13,6 +13,11 @@
- KDIR ?= /lib/modules/$(shell uname -r)/build
- PWD := $(shell pwd)
-
-+soloscli/soloscli:
-+ $(MAKE) -C soloscli
-+
-+install:
-+
- default:
- $(MAKE) -C $(KDIR) M=$(PWD) modules
-
-@@ -20,5 +25,6 @@
- rm -f *.o *.ko *.mod.c .*.cmd
- rm -rf .tmp_versions
- rm -f Module.symvers
-+ $(MAKE) -C soloscli clean
-
- endif
diff --git a/package/network/config/soloscli/patches/001-newline.patch b/package/network/config/soloscli/patches/001-newline.patch
deleted file mode 100644
index 4b663e8898..0000000000
--- a/package/network/config/soloscli/patches/001-newline.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/soloscli/soloscli.c
-+++ b/soloscli/soloscli.c
-@@ -238,7 +238,11 @@
- }
- if (strcmp(buf,pid) == 0) {
- /* printf("Sequence matches.\n"); */
-- printf("%s",bufp);
-+ if(buf[(len-1)] == '\n'){
-+ printf("%s",bufp);
-+ } else {
-+ printf("%s\n",bufp);
-+ }
- } else {
- printf("Sequence incorrect.\n");
- buf[i] = '\n';
diff --git a/package/network/config/soloscli/patches/001-no-driver.patch b/package/network/config/soloscli/patches/001-no-driver.patch
new file mode 100644
index 0000000000..95588aa056
--- /dev/null
+++ b/package/network/config/soloscli/patches/001-no-driver.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -11,7 +11,7 @@ else
+ KDIR ?= /lib/modules/$(shell uname -r)/build
+ PWD := $(shell pwd)
+
+-all: soloscli driver
++all: soloscli
+
+ soloscli: soloscli/soloscli
+
diff --git a/package/network/config/soloscli/patches/002-cflags.patch b/package/network/config/soloscli/patches/002-cflags.patch
new file mode 100644
index 0000000000..a7d6a86020
--- /dev/null
+++ b/package/network/config/soloscli/patches/002-cflags.patch
@@ -0,0 +1,12 @@
+--- a/soloscli/Makefile
++++ b/soloscli/Makefile
+@@ -4,9 +4,6 @@
+ # Last Mod: 2009-06-16
+ #
+
+-CC=gcc
+-CFLAGS=-Wall
+-
+ soloscli: soloscli.c soloscli.h
+
+ clean: