summaryrefslogtreecommitdiffstats
path: root/package/network/config/ipip/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2014-10-02 19:37:36 +0000
committerSteven Barth <cyrus@openwrt.org>2014-10-02 19:37:36 +0000
commit36b05bbed34c8f4192ea04d17a030fc78e6e5c4f (patch)
tree518c85667ba208134c6af66df7cbee8bc2c32716 /package/network/config/ipip/Makefile
parent73179a188c6eed4db08ed5f9e109fae17db6575e (diff)
downloadmaster-31e0f0ae-36b05bbed34c8f4192ea04d17a030fc78e6e5c4f.tar.gz
master-31e0f0ae-36b05bbed34c8f4192ea04d17a030fc78e6e5c4f.tar.bz2
master-31e0f0ae-36b05bbed34c8f4192ea04d17a030fc78e6e5c4f.zip
IPIP: IP in IP package support
The package supports IP in IP by registering the ipip protocol handler Following options are configurable -peeraddr (IPv4 remote address) -ipaddr (IPv4 local address) -ttl (time to live of encapsulating packet) -tos (type of service of encapsulating packet either inherit (outer header inherits the value of the inner header) or hex value) -df (don't fragment flag of encapsulating packet) -mtu (IPIP tunnel mtu) -tunlink (bind tunnel to this interface) -zone (firewall zone to which the IPIP tunnel will be added) Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> SVN-Revision: 42746
Diffstat (limited to 'package/network/config/ipip/Makefile')
-rw-r--r--package/network/config/ipip/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/network/config/ipip/Makefile b/package/network/config/ipip/Makefile
new file mode 100644
index 0000000000..98f7b78d5c
--- /dev/null
+++ b/package/network/config/ipip/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ipip
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ipip
+ SECTION:=net
+ CATEGORY:=Network
+ MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
+ TITLE:=IP in IP Tunnel config support
+ DEPENDS:= +kmod-ipip
+endef
+
+define Package/ipip/description
+ IP in IP Tunnel config support in /etc/config/network.
+endef
+
+define Build/Compile
+endef
+
+define Build/Configure
+endef
+
+define Package/ipip/install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/ipip.sh $(1)/lib/netifd/proto/ipip.sh
+endef
+
+$(eval $(call BuildPackage,ipip))