summaryrefslogtreecommitdiffstats
path: root/package/mtd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-06-16 23:34:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-06-16 23:34:38 +0000
commit2dcfed2eff694b155ef70ef20447da0a9347eb69 (patch)
treeb4db90cf3ca15e777122c80283593dc1e8eb3087 /package/mtd
parent4289fa555e4a2b1643112c6ad976c54777123782 (diff)
downloadmaster-31e0f0ae-2dcfed2eff694b155ef70ef20447da0a9347eb69.tar.gz
master-31e0f0ae-2dcfed2eff694b155ef70ef20447da0a9347eb69.tar.bz2
master-31e0f0ae-2dcfed2eff694b155ef70ef20447da0a9347eb69.zip
mtd: request locked pages when mmap'ing the FIS table, cures random segfaults in table rewrite until http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=2d4dc890b5c8fabd818a8586607e6843c4375e62 is added.
SVN-Revision: 21823
Diffstat (limited to 'package/mtd')
-rw-r--r--package/mtd/Makefile2
-rw-r--r--package/mtd/src/fis.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/mtd/Makefile b/package/mtd/Makefile
index 9438b96fdc..332ce3034c 100644
--- a/package/mtd/Makefile
+++ b/package/mtd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mtd
-PKG_RELEASE:=12
+PKG_RELEASE:=13
PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
STAMP_PREPARED := $(STAMP_PREPARED)_$(call confvar,CONFIG_MTD_REDBOOT_PARTS)
diff --git a/package/mtd/src/fis.c b/package/mtd/src/fis.c
index b285d24db4..559ca95069 100644
--- a/package/mtd/src/fis.c
+++ b/package/mtd/src/fis.c
@@ -77,7 +77,7 @@ fis_open(void)
goto error;
fis_erasesize = erasesize;
- desc = mmap(NULL, erasesize, PROT_READ|PROT_WRITE, MAP_SHARED, fis_fd, 0);
+ desc = mmap(NULL, erasesize, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_LOCKED, fis_fd, 0);
if (desc == MAP_FAILED)
goto error;