summaryrefslogtreecommitdiffstats
path: root/package/mac80211
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-13 22:41:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-13 22:41:46 +0000
commite97e09eb5af0772a7fccc614e39319fd3b7f0340 (patch)
treea18e5b4043c3424704fa2b931f47725f71680bea /package/mac80211
parentc512b90fd4a2ad52ae326c3d14acde457e9831c3 (diff)
downloadmaster-31e0f0ae-e97e09eb5af0772a7fccc614e39319fd3b7f0340.tar.gz
master-31e0f0ae-e97e09eb5af0772a7fccc614e39319fd3b7f0340.tar.bz2
master-31e0f0ae-e97e09eb5af0772a7fccc614e39319fd3b7f0340.zip
don't build mac80211 if the kernel version does not match
SVN-Revision: 9294
Diffstat (limited to 'package/mac80211')
-rw-r--r--package/mac80211/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index e6e858f847..800ae48994 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -72,6 +72,8 @@ ifneq ($(findstring 2.6.23,$(LINUX_VERSION)),)
$(INSTALL_DIR) $(1)/lib/wifi
$(INSTALL_DATA) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi
endef
+else
+ override CONFIG_PACKAGE_kmod-mac80211=
endif
$(eval $(call KernelPackage,mac80211))