summaryrefslogtreecommitdiffstats
path: root/package/mac80211
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-13 23:01:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-13 23:01:35 +0000
commitbb72b2a38ac79f76eaa5890a14669a1311f77685 (patch)
tree529a7328ad79be23a107505d6e0f013dc6f7bb10 /package/mac80211
parent55a3969ee1ee1da922bb685a9a11a474acb076bd (diff)
downloadmaster-31e0f0ae-bb72b2a38ac79f76eaa5890a14669a1311f77685.tar.gz
master-31e0f0ae-bb72b2a38ac79f76eaa5890a14669a1311f77685.tar.bz2
master-31e0f0ae-bb72b2a38ac79f76eaa5890a14669a1311f77685.zip
fix nl80211
SVN-Revision: 9296
Diffstat (limited to 'package/mac80211')
-rw-r--r--package/mac80211/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 800ae48994..bbc8a6ca48 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -32,19 +32,20 @@ define KernelPackage/mac80211/description
Linux 802.11 Wireless Networking Stack
endef
-CONFOPTS:=MAC80211 CFG80211 NL80211
+CONFOPTS:=MAC80211 CFG80211
BUILDFLAGS:= \
$(foreach opt,$(CONFOPTS),-DCONFIG_$(opt) ) \
- $(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS)
+ $(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS -DCONFIG_NL80211)
MAKE_OPTS:= \
CROSS_COMPILE="$(TARGET_CROSS)" \
ARCH="$(LINUX_KARCH)" \
EXTRA_CFLAGS="$(BUILDFLAGS)" \
$(foreach opt,$(CONFOPTS),CONFIG_$(opt)=m) \
+ CONFIG_NL80211=y \
CONFIG_MAC80211_LEDS=$(CONFIG_LEDS_TRIGGERS) \
- LINUXINCLUDE="-I${CURDIR}/src/include -I$(LINUX_DIR)/include -include linux/autoconf.h"
+ LINUXINCLUDE="-I${CURDIR}/src/include -I$(LINUX_DIR)/include -include linux/autoconf.h" \
ifneq ($(findstring 2.6.23,$(LINUX_VERSION)),)
define Build/Prepare