summaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-23 22:01:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-23 22:01:45 +0000
commit9fce92753fbaf50f800e991a20f697566374f7e8 (patch)
tree8ab5d0659a08293c83cb025306b79e175f50565f /package/mac80211/patches
parentd6cb0680980c2224093082bc3640c4799366b6a0 (diff)
downloadmaster-31e0f0ae-9fce92753fbaf50f800e991a20f697566374f7e8.tar.gz
master-31e0f0ae-9fce92753fbaf50f800e991a20f697566374f7e8.tar.bz2
master-31e0f0ae-9fce92753fbaf50f800e991a20f697566374f7e8.zip
separate ath9k debugfs support from ath9k debugging, use the mac80211 debugfs config option to enable it
SVN-Revision: 18505
Diffstat (limited to 'package/mac80211/patches')
-rw-r--r--package/mac80211/patches/520-ath9k_debugfs_config.patch81
-rw-r--r--package/mac80211/patches/530-ath9k_debugfs_chainmask.patch (renamed from package/mac80211/patches/520-ath9k_debugfs_chainmask.patch)12
-rw-r--r--package/mac80211/patches/540-ath9k_debugfs_regaccess.patch (renamed from package/mac80211/patches/530-ath9k_debugfs_regaccess.patch)6
3 files changed, 90 insertions, 9 deletions
diff --git a/package/mac80211/patches/520-ath9k_debugfs_config.patch b/package/mac80211/patches/520-ath9k_debugfs_config.patch
new file mode 100644
index 0000000000..021338307d
--- /dev/null
+++ b/package/mac80211/patches/520-ath9k_debugfs_config.patch
@@ -0,0 +1,81 @@
+--- a/drivers/net/wireless/ath/ath9k/Makefile
++++ b/drivers/net/wireless/ath/ath9k/Makefile
+@@ -7,7 +7,7 @@ ath9k-y += beacon.o \
+
+ ath9k-$(CONFIG_PCI) += pci.o
+ ath9k-$(CONFIG_ATHEROS_AR71XX) += ahb.o
+-ath9k-$(CONFIG_ATH9K_DEBUG) += debug.o
++ath9k-$(CONFIG_ATH9K_DEBUGFS) += debug.o
+
+ obj-$(CONFIG_ATH9K) += ath9k.o
+
+--- a/drivers/net/wireless/ath/ath9k/ath9k.h
++++ b/drivers/net/wireless/ath/ath9k/ath9k.h
+@@ -483,7 +483,7 @@ struct ath_softc {
+
+ int beacon_interval;
+
+-#ifdef CONFIG_ATH9K_DEBUG
++#ifdef CONFIG_ATH9K_DEBUGFS
+ struct ath9k_debug debug;
+ #endif
+ struct ath_beacon_config cur_beacon_conf;
+--- a/drivers/net/wireless/ath/ath9k/debug.c
++++ b/drivers/net/wireless/ath/ath9k/debug.c
+@@ -31,6 +31,8 @@ static int ath9k_debugfs_open(struct ino
+ return 0;
+ }
+
++#ifdef CONFIG_ATH_DEBUG
++
+ static ssize_t read_file_debug(struct file *file, char __user *user_buf,
+ size_t count, loff_t *ppos)
+ {
+@@ -71,6 +73,8 @@ static const struct file_operations fops
+ .owner = THIS_MODULE
+ };
+
++#endif
++
+ static ssize_t read_file_dma(struct file *file, char __user *user_buf,
+ size_t count, loff_t *ppos)
+ {
+@@ -563,10 +567,12 @@ int ath9k_init_debug(struct ath_hw *ah)
+ if (!sc->debug.debugfs_phy)
+ goto err;
+
++#ifdef CONFIG_ATH_DEBUG
+ sc->debug.debugfs_debug = debugfs_create_file("debug",
+ S_IRUSR | S_IWUSR, sc->debug.debugfs_phy, sc, &fops_debug);
+ if (!sc->debug.debugfs_debug)
+ goto err;
++#endif
+
+ sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
+ sc->debug.debugfs_phy, sc, &fops_dma);
+--- a/drivers/net/wireless/ath/ath9k/debug.h
++++ b/drivers/net/wireless/ath/ath9k/debug.h
+@@ -23,13 +23,13 @@
+ struct ath_txq;
+ struct ath_buf;
+
+-#ifdef CONFIG_ATH9K_DEBUG
++#ifdef CONFIG_ATH9K_DEBUGFS
+ #define TX_STAT_INC(q, c) sc->debug.stats.txstats[q].c++
+ #else
+ #define TX_STAT_INC(q, c) do { } while (0)
+ #endif
+
+-#ifdef CONFIG_ATH9K_DEBUG
++#ifdef CONFIG_ATH9K_DEBUGFS
+
+ /**
+ * struct ath_interrupt_stats - Contains statistics about interrupts
+@@ -186,6 +186,6 @@ static inline void ath_debug_stat_retrie
+ {
+ }
+
+-#endif /* CONFIG_ATH9K_DEBUG */
++#endif /* CONFIG_ATH9K_DEBUGFS */
+
+ #endif /* DEBUG_H */
diff --git a/package/mac80211/patches/520-ath9k_debugfs_chainmask.patch b/package/mac80211/patches/530-ath9k_debugfs_chainmask.patch
index d8ca8dfbfb..a26b4dc8aa 100644
--- a/package/mac80211/patches/520-ath9k_debugfs_chainmask.patch
+++ b/package/mac80211/patches/530-ath9k_debugfs_chainmask.patch
@@ -1,8 +1,8 @@
--- a/drivers/net/wireless/ath/ath9k/debug.c
+++ b/drivers/net/wireless/ath/ath9k/debug.c
-@@ -71,6 +71,90 @@ static const struct file_operations fops
- .owner = THIS_MODULE
- };
+@@ -75,6 +75,90 @@ static const struct file_operations fops
+
+ #endif
+static ssize_t read_file_tx_chainmask(struct file *file, char __user *user_buf,
+ size_t count, loff_t *ppos)
@@ -91,9 +91,9 @@
static ssize_t read_file_dma(struct file *file, char __user *user_buf,
size_t count, loff_t *ppos)
{
-@@ -568,6 +652,16 @@ int ath9k_init_debug(struct ath_hw *ah)
- if (!sc->debug.debugfs_debug)
+@@ -574,6 +658,16 @@ int ath9k_init_debug(struct ath_hw *ah)
goto err;
+ #endif
+ sc->debug.debugfs_rx_chainmask = debugfs_create_file("rx_chainmask",
+ S_IRUSR | S_IWUSR, sc->debug.debugfs_phy, sc, &fops_rx_chainmask);
@@ -108,7 +108,7 @@
sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
sc->debug.debugfs_phy, sc, &fops_dma);
if (!sc->debug.debugfs_dma)
-@@ -611,6 +705,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
+@@ -617,6 +711,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
struct ath_common *common = ath9k_hw_common(ah);
struct ath_softc *sc = (struct ath_softc *) common->priv;
diff --git a/package/mac80211/patches/530-ath9k_debugfs_regaccess.patch b/package/mac80211/patches/540-ath9k_debugfs_regaccess.patch
index b973dbb2aa..b927b55137 100644
--- a/package/mac80211/patches/530-ath9k_debugfs_regaccess.patch
+++ b/package/mac80211/patches/540-ath9k_debugfs_regaccess.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/ath9k/debug.c
+++ b/drivers/net/wireless/ath/ath9k/debug.c
-@@ -634,6 +634,86 @@ static const struct file_operations fops
+@@ -638,6 +638,86 @@ static const struct file_operations fops
.owner = THIS_MODULE
};
@@ -87,7 +87,7 @@
int ath9k_init_debug(struct ath_hw *ah)
{
struct ath_common *common = ath9k_hw_common(ah);
-@@ -694,6 +774,17 @@ int ath9k_init_debug(struct ath_hw *ah)
+@@ -700,6 +780,17 @@ int ath9k_init_debug(struct ath_hw *ah)
if (!sc->debug.debugfs_xmit)
goto err;
@@ -105,7 +105,7 @@
return 0;
err:
ath9k_exit_debug(ah);
-@@ -707,6 +798,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
+@@ -713,6 +804,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
debugfs_remove(sc->debug.debugfs_tx_chainmask);
debugfs_remove(sc->debug.debugfs_rx_chainmask);