summaryrefslogtreecommitdiffstats
path: root/package/linux-atm
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-03-23 14:32:14 +0000
committerNicolas Thill <nico@openwrt.org>2010-03-23 14:32:14 +0000
commit4e0681e1db6317b8bdf0d097b53e8a8f03b7c6b1 (patch)
tree26f091084667f32212e6ae92ac250591532632ba /package/linux-atm
parentc0ea2a62575f24530c55eb792335f489c37998bf (diff)
downloadmaster-31e0f0ae-4e0681e1db6317b8bdf0d097b53e8a8f03b7c6b1.tar.gz
master-31e0f0ae-4e0681e1db6317b8bdf0d097b53e8a8f03b7c6b1.tar.bz2
master-31e0f0ae-4e0681e1db6317b8bdf0d097b53e8a8f03b7c6b1.zip
linux-atm: fix compilation of 'qgen' host tool
SVN-Revision: 20387
Diffstat (limited to 'package/linux-atm')
-rw-r--r--package/linux-atm/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index 8fd081b70f..38e903406e 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -40,11 +40,6 @@ define Package/atm-tools/description
This package contains the Linux ATM tools.
endef
-define Build/Prepare
- $(call Build/Prepare/Default)
- $(INSTALL_BIN) $(SCRIPT_DIR)/config.sub $(SCRIPT_DIR)/config.guess $(PKG_BUILD_DIR)/
-endef
-
define Build/Configure
$(call Build/Configure/Default)
# prevent autoheader invocation
@@ -52,6 +47,10 @@ define Build/Configure
endef
define Build/Compile
+ # src/qgen is built with HOSTCC, which does not really like our LDFLAGS
+ $(MAKE) -C $(PKG_BUILD_DIR)/src/qgen \
+ LDFLAGS="" \
+ all
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install