summaryrefslogtreecommitdiffstats
path: root/package/linux-atm/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commitc2211dc51e98fa27d565c44179c3044723e69253 (patch)
treed97c293836c481a19206daabf6f6dd18c5a1e2d3 /package/linux-atm/Makefile
parentd48cc978a7c8c0b6466eec7bf063f78a99e287cb (diff)
downloadmaster-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.gz
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.bz2
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.zip
replace lots of manual install commands with INSTALL_* variables
SVN-Revision: 5624
Diffstat (limited to 'package/linux-atm/Makefile')
-rw-r--r--package/linux-atm/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index ced3da69ef..9aae0a0b0e 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -73,15 +73,15 @@ define Build/UninstallDev
endef
define Package/linux-atm/install
- install -d -m0755 $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/usr/lib
cp -f $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(1)/usr/lib
endef
define Package/br2684ctl/install
- install -d -m0755 $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
- install -d -m0755 $(1)/etc/hotplug.d/net
- install -m0644 ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/net
+ $(INSTALL_DATA) ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
endef
$(eval $(call BuildPackage,linux-atm))