summaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorDirk Feytons <dirk.feytons@gmail.com>2016-06-10 12:02:15 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-23 12:10:41 +0200
commit3ad8bc4366f8147b116addf37bac458e7b1648af (patch)
tree25725f3f0e3036e25e889a0f71399f45295e0223 /package/libs
parent057b116e092aa7386f610dc6682cb400e4276314 (diff)
downloadmaster-31e0f0ae-3ad8bc4366f8147b116addf37bac458e7b1648af.tar.gz
master-31e0f0ae-3ad8bc4366f8147b116addf37bac458e7b1648af.tar.bz2
master-31e0f0ae-3ad8bc4366f8147b116addf37bac458e7b1648af.zip
openssl: add option to disable SRP support
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/openssl/Config.in5
-rw-r--r--package/libs/openssl/Makefile7
2 files changed, 11 insertions, 1 deletions
diff --git a/package/libs/openssl/Config.in b/package/libs/openssl/Config.in
index 7224b65a4b..e1d9952a37 100644
--- a/package/libs/openssl/Config.in
+++ b/package/libs/openssl/Config.in
@@ -35,6 +35,11 @@ config OPENSSL_WITH_PSK
default y
prompt "Enable PSK support"
+config OPENSSL_WITH_SRP
+ bool
+ default y
+ prompt "Enable SRP support"
+
config OPENSSL_ENGINE_DIGEST
bool
depends on OPENSSL_ENGINE_CRYPTO
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 393976598b..0181dced85 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -36,7 +36,8 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_OPENSSL_WITH_DEPRECATED \
CONFIG_OPENSSL_WITH_COMPRESSION \
CONFIG_OPENSSL_WITH_NPN \
- CONFIG_OPENSSL_WITH_PSK
+ CONFIG_OPENSSL_WITH_PSK \
+ CONFIG_OPENSSL_WITH_SRP
include $(INCLUDE_DIR)/package.mk
@@ -142,6 +143,10 @@ ifndef CONFIG_OPENSSL_WITH_PSK
OPENSSL_OPTIONS += no-psk
endif
+ifndef CONFIG_OPENSSL_WITH_SRP
+ OPENSSL_OPTIONS += no-srp
+endif
+
ifeq ($(CONFIG_x86_64),y)
OPENSSL_TARGET:=linux-x86_64-openwrt
OPENSSL_MAKEFLAGS += LIBDIR=lib