summaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorDirk Feytons <dirk.feytons@gmail.com>2016-06-02 13:43:14 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-23 12:10:08 +0200
commit057b116e092aa7386f610dc6682cb400e4276314 (patch)
tree7ac981d78e999e66d858321474b0e7fce1508f5f /package/libs
parent41da31ac2ca2306e9cff070f650f6012af753517 (diff)
downloadmaster-31e0f0ae-057b116e092aa7386f610dc6682cb400e4276314.tar.gz
master-31e0f0ae-057b116e092aa7386f610dc6682cb400e4276314.tar.bz2
master-31e0f0ae-057b116e092aa7386f610dc6682cb400e4276314.zip
openssl: add --gc-sections
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/openssl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 8e439e1c31..393976598b 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -184,7 +184,8 @@ define Build/Configure
depend
endef
-TARGET_CFLAGS += $(FPIC) -I$(CURDIR)/include
+TARGET_CFLAGS += $(FPIC) -I$(CURDIR)/include -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \