summaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-14 18:27:12 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-14 18:27:12 +0200
commitaddfc0efdd1077d1d8019b73448b4aa1f08442ba (patch)
tree7c243bd35c8ac5fcb51a2f9d1ccd144516910da8 /package/libs
parentda46d2b228f67bf0ef89d7c4905c548918763f51 (diff)
downloadmaster-31e0f0ae-addfc0efdd1077d1d8019b73448b4aa1f08442ba.tar.gz
master-31e0f0ae-addfc0efdd1077d1d8019b73448b4aa1f08442ba.tar.bz2
master-31e0f0ae-addfc0efdd1077d1d8019b73448b4aa1f08442ba.zip
uclibc++: add hack to fix failing patch
One of the patched files, include/unwind-cxx.h, contains windows newlines which lead to the following failure: Applying ./patches/006-eabi_fix.patch using plaintext: patching file include/typeinfo patching file include/unwind-cxx.h Hunk #1 FAILED at 173 (different line endings). Hunk #2 FAILED at 181 (different line endings). Add a fixup command to the prepare phase which normalizes the line endings before applying source patches. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/uclibc++/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/libs/uclibc++/Makefile b/package/libs/uclibc++/Makefile
index a4dceb7a3b..4c7c7678e3 100644
--- a/package/libs/uclibc++/Makefile
+++ b/package/libs/uclibc++/Makefile
@@ -1,5 +1,6 @@
#
# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (c) 2016 LEDE project
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uclibc++
PKG_VERSION:=0.2.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=uClibc++-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://cxx.uclibc.org/src/
@@ -66,6 +67,12 @@ MAKE_FLAGS:= \
# check_as_needed overrides dependency on libgcc_s
+define Build/Prepare
+ $(PKG_UNPACK)
+ $(SED) 's/\r$$$$//' $(PKG_BUILD_DIR)/include/unwind-cxx.h
+ $(Build/Patch)
+endef
+
define Build/Configure
if [ -f ./files/config.$(UCLIBC_TARGET_ARCH) ]; then \
cp ./files/config.$(UCLIBC_TARGET_ARCH) $(PKG_BUILD_DIR)/.config; \