summaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-11-06 19:35:34 +0000
committerNicolas Thill <nico@openwrt.org>2014-11-06 19:35:34 +0000
commitf4417f7ad8f2da7d99c48eead14b0a2e8ad0f387 (patch)
treea0e28ec68139151407b3a76169cba65a52840029 /package/libs/toolchain/Makefile
parentbd92e9806b35a0d9f6d8351eb274d2cdfcc142b9 (diff)
downloadmaster-31e0f0ae-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.tar.gz
master-31e0f0ae-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.tar.bz2
master-31e0f0ae-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.zip
package/*: replace occurences of 'ln -sf' to '$(LN)'
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 43205
Diffstat (limited to 'package/libs/toolchain/Makefile')
-rw-r--r--package/libs/toolchain/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index be20c06424..1cb83fa126 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -427,7 +427,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/eglibc/install
$(CP) ./eglibc-files/* $(1)/
rm -f $(1)/etc/localtime
- ln -sf /tmp/localtime $(1)/etc/localtime
+ $(LN) /tmp/localtime $(1)/etc/localtime
$(INSTALL_DIR) $(1)/lib
$(CP) \
$(TOOLCHAIN_DIR)/lib/ld*.so.* \
@@ -476,7 +476,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(CP) \
$(TOOLCHAIN_DIR)/lib/libc.so* \
$(1)/lib/
- ln -s ../../lib/$(LD_MUSL_NAME) $(1)/usr/bin/ldd
+ $(LN) ../../lib/$(LD_MUSL_NAME) $(1)/usr/bin/ldd
endef
define Package/libc/install