summaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-19 21:45:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-19 21:45:58 +0000
commit4c4157e2878f90faea20c50d06b71783a9d2c15f (patch)
treec9e890c6223cc156eb53a480f380427ecd2926ac /package/libs/toolchain/Makefile
parent81cc26c706b2bc8c8c1eb1a322e5c5157900836e (diff)
downloadmaster-31e0f0ae-4c4157e2878f90faea20c50d06b71783a9d2c15f.tar.gz
master-31e0f0ae-4c4157e2878f90faea20c50d06b71783a9d2c15f.tar.bz2
master-31e0f0ae-4c4157e2878f90faea20c50d06b71783a9d2c15f.zip
toolchain: when using musl, install a symlink from ld-musl-*.so to /usr/bin/ldd
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42974
Diffstat (limited to 'package/libs/toolchain/Makefile')
-rw-r--r--package/libs/toolchain/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 72ce6b90e1..1de0c2807a 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -468,13 +468,14 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/ld-musl-*.so*)))
define Package/musl/install
- $(INSTALL_DIR) $(1)/lib
+ $(INSTALL_DIR) $(1)/lib $(1)/usr/bin
$(CP) \
$(TOOLCHAIN_DIR)/lib/ld-musl-*.so* \
$(1)/lib/
$(CP) \
$(TOOLCHAIN_DIR)/lib/libc.so* \
$(1)/lib/
+ ln -s ../../lib/$(LD_MUSL_NAME) $(1)/usr/bin/ldd
$(if $(findstring -sf.so,$(LD_MUSL_NAME)),ln -s $(LD_MUSL_NAME) $(1)/lib/$(subst -sf.so,.so,$(LD_MUSL_NAME)))
endef