summaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-11-19 12:17:34 +0000
committerJonas Gorski <jogo@openwrt.org>2014-11-19 12:17:34 +0000
commit4b16b9015253abe3fa1d42ed0e367c5b7a0e8398 (patch)
treebd148c39238fd4cfc5365d8925ac1464d96bc954 /package/libs/toolchain/Makefile
parent2d09efcd26be6ba4d004691fce1db1e382501d26 (diff)
downloadmaster-31e0f0ae-4b16b9015253abe3fa1d42ed0e367c5b7a0e8398.tar.gz
master-31e0f0ae-4b16b9015253abe3fa1d42ed0e367c5b7a0e8398.tar.bz2
master-31e0f0ae-4b16b9015253abe3fa1d42ed0e367c5b7a0e8398.zip
toolchain: musl: fix symlink for ldd
ld-musl-*.so* is a symlink "broken" for the hostsystem, so wildcard will skip it, causing LD_MUSL_NAME to empty and the ldd symlink pointing to ../../lib directly. This causes sysupgrade failing to copy any linked libaries and consequently failing to run anything after switching to ram disk. Fix this by creating a symlink directly pointing to where ld-musl-*.so* points to. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 43314
Diffstat (limited to 'package/libs/toolchain/Makefile')
-rw-r--r--package/libs/toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 1cb83fa126..10c990a126 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -466,7 +466,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(1)/lib/
endef
- LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/ld-musl-*.so*)))
+ LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/libc.so*)))
define Package/musl/install
$(INSTALL_DIR) $(1)/lib $(1)/usr/bin