summaryrefslogtreecommitdiffstats
path: root/package/libs/popt
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-17 12:52:28 +0000
committerJohn Crispin <john@openwrt.org>2015-01-17 12:52:28 +0000
commit748d45289980de78e727060b68230392c1efbb6f (patch)
tree603b471cc1a85439c7e35f14e499de7127936832 /package/libs/popt
parent18f76fbef178831085ffa5d6a3783b2f20c9dbfa (diff)
downloadmaster-31e0f0ae-748d45289980de78e727060b68230392c1efbb6f.tar.gz
master-31e0f0ae-748d45289980de78e727060b68230392c1efbb6f.tar.bz2
master-31e0f0ae-748d45289980de78e727060b68230392c1efbb6f.zip
add pkgconfig information for popt library
Modify makefile to record pkgconfig information for the popt library. Signed-off-by: Mike Brady <mikebrady@eircom.net> SVN-Revision: 43994
Diffstat (limited to 'package/libs/popt')
-rw-r--r--package/libs/popt/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libs/popt/Makefile b/package/libs/popt/Makefile
index bd2e6e2883..b31b311513 100644
--- a/package/libs/popt/Makefile
+++ b/package/libs/popt/Makefile
@@ -45,6 +45,8 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/popt.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/popt.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libpopt/install