summaryrefslogtreecommitdiffstats
path: root/package/libs/openssl
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-02-09 15:26:35 +0000
committerSteven Barth <cyrus@openwrt.org>2015-02-09 15:26:35 +0000
commit909af3fa4b433c2b6bded30a17564633bc14c7c1 (patch)
treeda9e5a6bc9a5bccee297607d37896333fa6c5fa4 /package/libs/openssl
parented84ceaa02386efa5eb46ac24abb644a1d176cfd (diff)
downloadmaster-31e0f0ae-909af3fa4b433c2b6bded30a17564633bc14c7c1.tar.gz
master-31e0f0ae-909af3fa4b433c2b6bded30a17564633bc14c7c1.tar.bz2
master-31e0f0ae-909af3fa4b433c2b6bded30a17564633bc14c7c1.zip
openssl: fix upstream regression for non-ec builds
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 44364
Diffstat (limited to 'package/libs/openssl')
-rw-r--r--package/libs/openssl/Makefile2
-rw-r--r--package/libs/openssl/patches/220-fix-no-ec-build.patch14
2 files changed, 15 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 7a21e51c5f..42165a733c 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=1.0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_USE_MIPS16:=0
PKG_BUILD_PARALLEL:=1
diff --git a/package/libs/openssl/patches/220-fix-no-ec-build.patch b/package/libs/openssl/patches/220-fix-no-ec-build.patch
new file mode 100644
index 0000000000..44ec50eae4
--- /dev/null
+++ b/package/libs/openssl/patches/220-fix-no-ec-build.patch
@@ -0,0 +1,14 @@
+--- a/ssl/t1_lib.c
++++ b/ssl/t1_lib.c
+@@ -113,9 +113,11 @@
+ #include <openssl/objects.h>
+ #include <openssl/evp.h>
+ #include <openssl/hmac.h>
++#ifndef OPENSSL_NO_EC
+ #ifdef OPENSSL_NO_EC2M
+ # include <openssl/ec.h>
+ #endif
++#endif
+ #include <openssl/ocsp.h>
+ #include <openssl/rand.h>
+ #include "ssl_locl.h"