summaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorDirk Feytons <dirk.feytons@gmail.com>2016-05-20 15:34:02 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-23 12:09:51 +0200
commit41da31ac2ca2306e9cff070f650f6012af753517 (patch)
tree78275bfaf741514d6036fc64d391b6885525dfb3 /package/libs/openssl/Makefile
parentf16fc21675d3335061d7afeaff9c252f0fc7fd1e (diff)
downloadmaster-31e0f0ae-41da31ac2ca2306e9cff070f650f6012af753517.tar.gz
master-31e0f0ae-41da31ac2ca2306e9cff070f650f6012af753517.tar.bz2
master-31e0f0ae-41da31ac2ca2306e9cff070f650f6012af753517.zip
openssl: remove some unneeded functionality and algorithms
The patch needed for this commit has been sent upstream: https://github.com/openssl/openssl/pull/1155 Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com> Signed-off-by: Felix Fietkau <nbd@nbd.name> [add back bf and srp]
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 7cd306ba63..8e439e1c31 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -95,8 +95,9 @@ This package contains the OpenSSL command-line utility.
endef
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-camellia no-krb5
-OPENSSL_OPTIONS:= shared no-err no-sse2 no-ssl2
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-camellia no-krb5 \
+ no-whrlpool no-whirlpool no-ripemd no-seed no-cast no-cmac
+OPENSSL_OPTIONS:= shared no-err no-sse2 no-ssl2 no-ssl2-method no-heartbeats
ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
OPENSSL_OPTIONS += -DHAVE_CRYPTODEV
@@ -116,7 +117,7 @@ ifndef CONFIG_OPENSSL_WITH_EC2M
endif
ifndef CONFIG_OPENSSL_WITH_SSL3
- OPENSSL_OPTIONS += no-ssl3
+ OPENSSL_OPTIONS += no-ssl3 no-ssl3-method
endif
ifndef CONFIG_OPENSSL_HARDWARE_SUPPORT