summaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-12 18:35:04 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-12 19:35:32 +0200
commit3d6d5ccf593a1e2c537756002f82e96760daf4ac (patch)
tree20382ca1839a4ea2b704e6fe72f8bce6ac357002 /package/libs/openssl/Makefile
parentf816472f78e40dbfc33d59964140808cb29baed7 (diff)
downloadmaster-31e0f0ae-3d6d5ccf593a1e2c537756002f82e96760daf4ac.tar.gz
master-31e0f0ae-3d6d5ccf593a1e2c537756002f82e96760daf4ac.tar.bz2
master-31e0f0ae-3d6d5ccf593a1e2c537756002f82e96760daf4ac.zip
openssl: replace ocf-crypto-headers with a header file from cryptodev-linux
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 3baf98c04e..0d86223016 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -26,7 +26,6 @@ PKG_MD5SUM:=9392e65072ce4b614c1392eefc1f23d0
PKG_LICENSE:=OpenSSL
PKG_LICENSE_FILES:=LICENSE
-PKG_BUILD_DEPENDS:=ocf-crypto-headers
PKG_CONFIG_DEPENDS:= \
CONFIG_OPENSSL_ENGINE_CRYPTO \
CONFIG_OPENSSL_ENGINE_DIGEST \
@@ -162,7 +161,7 @@ define Build/Configure
depend
endef
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -I$(CURDIR)/include
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \