summaryrefslogtreecommitdiffstats
path: root/package/libs/ncurses
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-05 23:18:42 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-05 23:18:42 +0000
commit66fe4fd966cadf9b2a2fa3af75bd8aba63daa918 (patch)
tree336d7a236f20ae5e24308a3722178efdebe1e318 /package/libs/ncurses
parente1c95ffb930e690d703f503c24f9a1d7e292878a (diff)
downloadmaster-31e0f0ae-66fe4fd966cadf9b2a2fa3af75bd8aba63daa918.tar.gz
master-31e0f0ae-66fe4fd966cadf9b2a2fa3af75bd8aba63daa918.tar.bz2
master-31e0f0ae-66fe4fd966cadf9b2a2fa3af75bd8aba63daa918.zip
ncurses: add host build for 'tic'
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44282
Diffstat (limited to 'package/libs/ncurses')
-rw-r--r--package/libs/ncurses/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index 5d6e8fe2ab..3e087f9497 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -22,7 +22,10 @@ PKG_LICENSE_FILES:=README
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+PKG_BUILD_DEPENDS:=ncurses/host
+
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/libncurses
SECTION:=libs
@@ -58,8 +61,10 @@ CONFIGURE_ARGS += \
--disable-rpath \
--without-ada \
--without-debug \
+ --without-manpages \
--without-profile \
--without-progs \
+ --without-tests \
--disable-big-core \
--disable-home-terminfo \
--with-normal \
@@ -67,6 +72,17 @@ CONFIGURE_ARGS += \
--with-terminfo-dirs=/usr/share/terminfo \
--with-default-terminfo-dir=/usr/share/terminfo
+HOST_CONFIGURE_ARGS += \
+ --without-cxx \
+ --without-cxx-binding \
+ --without-ada \
+ --without-debug \
+ --without-manpages \
+ --without-profile \
+ --without-tests \
+ --without-curses-h
+
+
ifeq ($(HOST_OS),FreeBSD)
CONFIGURE_ARGS +=
--with-terminfo=/usr/share/terminfo.db
@@ -149,6 +165,17 @@ define Build/InstallDev
endef
endif
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) libs
+ $(MAKE) -C $(HOST_BUILD_DIR)/progs tic
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/progs/tic $(STAGING_DIR_HOST)/bin/tic
+endef
+
+$(eval $(call HostBuild))
$(eval $(call BuildPackage,terminfo))
$(eval $(call BuildPackage,libncurses))
$(eval $(call BuildPackage,libncursesw))