summaryrefslogtreecommitdiffstats
path: root/package/libs/libusb
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-11 16:14:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-11 16:14:23 +0000
commit2ff6a5f6186aaaf677e3b475f66512f3fb8b6ba1 (patch)
treee6acc1b444e0833ba7811844cdf6639b5e315d40 /package/libs/libusb
parentb78cddafcc74d83fe93057bd8623ae0701a4c93f (diff)
downloadmaster-31e0f0ae-2ff6a5f6186aaaf677e3b475f66512f3fb8b6ba1.tar.gz
master-31e0f0ae-2ff6a5f6186aaaf677e3b475f66512f3fb8b6ba1.tar.bz2
master-31e0f0ae-2ff6a5f6186aaaf677e3b475f66512f3fb8b6ba1.zip
libusb: update to version 1.0.19
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43930
Diffstat (limited to 'package/libs/libusb')
-rw-r--r--package/libs/libusb/Makefile7
-rw-r--r--package/libs/libusb/patches/001-timerfd.patch16
2 files changed, 13 insertions, 10 deletions
diff --git a/package/libs/libusb/Makefile b/package/libs/libusb/Makefile
index 2796b051d5..d2493fd26e 100644
--- a/package/libs/libusb/Makefile
+++ b/package/libs/libusb/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libusb
-PKG_VERSION:=1.0.9
+PKG_VERSION:=1.0.19
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=7f5a02375ad960d4e33a6dae7d63cfcb
+PKG_MD5SUM:=f9e2bb5879968467e5ca756cb4e1fa7e
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
@@ -37,6 +37,9 @@ define Package/libusb-1.0/description
endef
TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += \
+ --disable-udev \
+ --disable-log
define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
diff --git a/package/libs/libusb/patches/001-timerfd.patch b/package/libs/libusb/patches/001-timerfd.patch
index de48a7fd9b..d14e3dcba7 100644
--- a/package/libs/libusb/patches/001-timerfd.patch
+++ b/package/libs/libusb/patches/001-timerfd.patch
@@ -14,15 +14,15 @@ Date: Thu Jan 27 06:39:16 2011 +0300
--- a/libusb/io.c
+++ b/libusb/io.c
-@@ -20,6 +20,7 @@
-
- #include <config.h>
- #include <errno.h>
+@@ -32,6 +32,7 @@
+ #include <sys/time.h>
+ #endif
+ #ifdef USBI_TIMERFD_AVAILABLE
+#include <fcntl.h>
- #include <signal.h>
- #include <stdint.h>
- #include <stdlib.h>
-@@ -1072,7 +1073,7 @@ int usbi_io_init(struct libusb_context *
+ #include <sys/timerfd.h>
+ #endif
+
+@@ -1141,7 +1142,7 @@ int usbi_io_init(struct libusb_context *
#ifdef USBI_TIMERFD_AVAILABLE
ctx->timerfd = timerfd_create(usbi_backend->get_timerfd_clockid(),