summaryrefslogtreecommitdiffstats
path: root/package/libs/libunwind/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2016-06-09 10:04:23 +0800
committerJohn Crispin <john@phrozen.org>2016-06-13 22:51:43 +0200
commit987f14ab2343ae32bbeaa02fbdc34dfb235f8f7c (patch)
tree376eb37f7f33a9d4061799cbbe49cda817bb2cf0 /package/libs/libunwind/Makefile
parent9a4935687d6d79e0eeae37204794fc68e17c8b68 (diff)
downloadmaster-31e0f0ae-987f14ab2343ae32bbeaa02fbdc34dfb235f8f7c.tar.gz
master-31e0f0ae-987f14ab2343ae32bbeaa02fbdc34dfb235f8f7c.tar.bz2
master-31e0f0ae-987f14ab2343ae32bbeaa02fbdc34dfb235f8f7c.zip
libunwind: initial version 1.1
The package Makefile was based on work at link [1] with the following changes 1. Disable minidebuginfo support thus no dependency on liblzma 2. Add 2 patches for building against musl-libc and building with mips16 enabled 3. Add LICENSE and DEPENDS info, etc. [1] https://github.com/rpi-openwrt/rpi-packages/tree/master/libs/libunwind Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/libs/libunwind/Makefile')
-rw-r--r--package/libs/libunwind/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/package/libs/libunwind/Makefile b/package/libs/libunwind/Makefile
new file mode 100644
index 0000000000..ec19656ec9
--- /dev/null
+++ b/package/libs/libunwind/Makefile
@@ -0,0 +1,53 @@
+#
+# Copyright (C) 2008-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libunwind
+PKG_VERSION:=1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/libunwind
+PKG_MD5SUM:=fb4ea2f6fbbe45bf032cd36e586883ce
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+PKG_LICENSE:=X11
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libunwind
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=The libunwind project
+ URL:=http://www.nongnu.org/libunwind/
+ DEPENDS:=@(mips||mipsel||powerpc||i386||x86_64)
+endef
+
+define Package/libunwind/description
+ Libunwind defines a portable and efficient C programming interface (API) to determine the call-chain of a program.
+endef
+
+CONFIGURE_ARGS += --enable-minidebuginfo=no
+
+define Package/libunwind/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunwin*.so* $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunwin*.so* $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+endef
+
+$(eval $(call BuildPackage,libunwind))