summaryrefslogtreecommitdiffstats
path: root/package/libs/libreadline
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-04-01 15:11:32 +0000
committerNicolas Thill <nico@openwrt.org>2015-04-01 15:11:32 +0000
commit32085b22b01c8b8ddc4bc7ae602fa23a4a369a18 (patch)
tree33737c8907efc3334432f09bcb03d73a9bfde131 /package/libs/libreadline
parentd1457d5db477cc7e6458ce6a2990c07c653e895d (diff)
downloadmaster-31e0f0ae-32085b22b01c8b8ddc4bc7ae602fa23a4a369a18.tar.gz
master-31e0f0ae-32085b22b01c8b8ddc4bc7ae602fa23a4a369a18.tar.bz2
master-31e0f0ae-32085b22b01c8b8ddc4bc7ae602fa23a4a369a18.zip
libreadline: cleanup Makefile, fix shlib perms
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 45223
Diffstat (limited to 'package/libs/libreadline')
-rw-r--r--package/libs/libreadline/Makefile29
-rw-r--r--package/libs/libreadline/patches/001-install_perm.patch11
2 files changed, 24 insertions, 16 deletions
diff --git a/package/libs/libreadline/Makefile b/package/libs/libreadline/Makefile
index a9e6a22163..21c8b21649 100644
--- a/package/libs/libreadline/Makefile
+++ b/package/libs/libreadline/Makefile
@@ -19,6 +19,8 @@ PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=COPYING
PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@@ -38,27 +40,22 @@ define Package/libreadline/description
history expansion on previous commands.
endef
-define Build/Configure
- $(CP) $(SCRIPT_DIR)/config.guess $(SCRIPT_DIR)/config.sub $(PKG_BUILD_DIR)/support/
- $(call Build/Configure/Default, \
- --enable-shared \
- --enable-static \
- --without-curses \
- bash_cv_wcwidth_broken=no \
- bash_cv_func_sigsetjmp=yes \
- )
-endef
+# prevent "autoreconf" from removing "aclocal.m4"
+PKG_REMOVE_FILES:=
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --with-curses \
+
+CONFIGURE_VARS += \
+ bash_cv_wcwidth_broken=no \
+ bash_cv_func_sigsetjmp=yes \
TARGET_CPPFLAGS:=-I. -I.. $(TARGET_CPPFLAGS)
TARGET_CFLAGS += $(FPIC)
-define Build/Compile
- $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
diff --git a/package/libs/libreadline/patches/001-install_perm.patch b/package/libs/libreadline/patches/001-install_perm.patch
new file mode 100644
index 0000000000..951ff73e5b
--- /dev/null
+++ b/package/libs/libreadline/patches/001-install_perm.patch
@@ -0,0 +1,11 @@
+--- a/support/shlib-install
++++ b/support/shlib-install
+@@ -73,7 +73,7 @@ fi
+ case "$host_os" in
+ hpux*|darwin*|macosx*|linux*|solaris2*)
+ if [ -z "$uninstall" ]; then
+- chmod 555 ${INSTALLDIR}/${LIBNAME}
++ chmod +x ${INSTALLDIR}/${LIBNAME}
+ fi ;;
+ cygwin*|mingw*)
+ IMPLIBNAME=`echo ${LIBNAME} \