summaryrefslogtreecommitdiffstats
path: root/package/libs/libpcap
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-09 11:03:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-09 11:03:00 +0000
commit430e641a08b66adbea31bfcc6b999845b38fb5cc (patch)
treeee951df443c8b1180cf84089b2e849f98944f08e /package/libs/libpcap
parentb93e5498ae0d99c0e5098745eca58332ec8e924a (diff)
downloadmaster-31e0f0ae-430e641a08b66adbea31bfcc6b999845b38fb5cc.tar.gz
master-31e0f0ae-430e641a08b66adbea31bfcc6b999845b38fb5cc.tar.bz2
master-31e0f0ae-430e641a08b66adbea31bfcc6b999845b38fb5cc.zip
IPv6 support should depend on if we've enabled it
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38349
Diffstat (limited to 'package/libs/libpcap')
-rw-r--r--package/libs/libpcap/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/libs/libpcap/Makefile b/package/libs/libpcap/Makefile
index f1d2872254..24b07c932b 100644
--- a/package/libs/libpcap/Makefile
+++ b/package/libs/libpcap/Makefile
@@ -54,7 +54,6 @@ CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--disable-yydebug \
- --enable-ipv6 \
--with-build-cc="$(HOSTCC)" \
--with-pcap=linux \
--without-septel \
@@ -62,6 +61,11 @@ CONFIGURE_ARGS += \
--without-libnl \
--disable-can
+ifeq ($(CONFIG_IPV6),y)
+CONFIGURE_ARGS += \
+ --enable-ipv6
+endif
+
MAKE_FLAGS += \
CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include"