summaryrefslogtreecommitdiffstats
path: root/package/libs/libnl-tiny/src/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-08 11:24:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-08 11:24:12 +0000
commit48db59fab785ce881e154d83115de86d284fce5d (patch)
tree8741bab5dbcca43c884cdf0788b6c0049e0c25d1 /package/libs/libnl-tiny/src/Makefile
parent997ace7e5e78d580d802f3f30ddc00f9b30e0bcc (diff)
downloadmaster-31e0f0ae-48db59fab785ce881e154d83115de86d284fce5d.tar.gz
master-31e0f0ae-48db59fab785ce881e154d83115de86d284fce5d.tar.bz2
master-31e0f0ae-48db59fab785ce881e154d83115de86d284fce5d.zip
move library packages to package/libs/
SVN-Revision: 33657
Diffstat (limited to 'package/libs/libnl-tiny/src/Makefile')
-rw-r--r--package/libs/libnl-tiny/src/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/libs/libnl-tiny/src/Makefile b/package/libs/libnl-tiny/src/Makefile
new file mode 100644
index 0000000000..f6f90ec7fe
--- /dev/null
+++ b/package/libs/libnl-tiny/src/Makefile
@@ -0,0 +1,17 @@
+CC=gcc
+WFLAGS=-Wall
+CFLAGS=-O2
+INCLUDES=-Iinclude
+
+LIBNAME=libnl-tiny.so
+
+all: $(LIBNAME)
+
+%.o: %.c
+ $(CC) $(WFLAGS) -c -o $@ $(INCLUDES) $(CFLAGS) $<
+
+LIBNL_OBJ=nl.o handlers.o msg.o attr.o cache.o cache_mngt.o object.o socket.o error.o
+GENL_OBJ=genl.o genl_family.o genl_ctrl.o genl_mngt.o unl.o
+
+$(LIBNAME): $(LIBNL_OBJ) $(GENL_OBJ)
+ $(CC) -shared -o $@ $^