summaryrefslogtreecommitdiffstats
path: root/package/libs/libjson-c/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-11 15:54:33 +0000
committerJohn Crispin <john@openwrt.org>2015-03-11 15:54:33 +0000
commit59c20174f84ee535c97c21c8dd5f8dfdaa5e47e1 (patch)
treee5fd4e122412f0e5b9c46ad4e4a34940af50e09a /package/libs/libjson-c/Makefile
parent24e29efb2f04526e3ff13d9a72e212b035c78dd7 (diff)
downloadmaster-31e0f0ae-59c20174f84ee535c97c21c8dd5f8dfdaa5e47e1.tar.gz
master-31e0f0ae-59c20174f84ee535c97c21c8dd5f8dfdaa5e47e1.tar.bz2
master-31e0f0ae-59c20174f84ee535c97c21c8dd5f8dfdaa5e47e1.zip
json-c: update to 0.12 and bump all depending services
Version 0.12 deprecates json_object_object_get and moves the header files around Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44657
Diffstat (limited to 'package/libs/libjson-c/Makefile')
-rw-r--r--package/libs/libjson-c/Makefile29
1 files changed, 3 insertions, 26 deletions
diff --git a/package/libs/libjson-c/Makefile b/package/libs/libjson-c/Makefile
index 4e0c47da3c..2b4c0a283e 100644
--- a/package/libs/libjson-c/Makefile
+++ b/package/libs/libjson-c/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=json-c
-PKG_VERSION:=0.11
-PKG_RELEASE:=2
+PKG_VERSION:=0.12
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
-PKG_MD5SUM:=aa02367d2f7a830bf1e3376f77881e98
+PKG_MD5SUM:=3ca4bbb881dfc4017e8021b5e0a8c491
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
@@ -38,30 +38,13 @@ define Package/libjson-c/description
This package contains a library for javascript object notation backends.
endef
-define Package/libjson
- SECTION:=libs
- CATEGORY:=Libraries
- DEPENDS:=+libjson-c
- TITLE:=javascript object notation (compat library)
- URL:=http://oss.metaparadigm.com/json-c/
-endef
-
-define Package/libjson/description
- This package contains a compatibility library for packages that have not
- been adapted to the json-c library rename yet
-endef
-
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/json $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/include/json-c $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json-c.pc $(1)/usr/lib/pkgconfig/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libjson-c/install
@@ -69,10 +52,4 @@ define Package/libjson-c/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.so.* $(1)/usr/lib/
endef
-define Package/libjson/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.so.* $(1)/usr/lib/
-endef
-
$(eval $(call BuildPackage,libjson-c))
-$(eval $(call BuildPackage,libjson))